• Rise from your gwave!

Ack!! >.<;; Need help with 21-pin mod-board!!&#3

Discussion in 'Saturn' started by MuttFox, Jun 7, 2002.

  1. MuttFox

    MuttFox New Member

    Well for starters, I had a h*ll of a time installing the g.d. thing... I bought it from lik-sang and used the instructions it pointed to on playthegames...but playthegames' instructions were all screwed up x.x it said to solder the timing wire to pin 3 of whatever chip it was...but it was actually like pin FOURTEEN or something like that.... ANYway, I finally got in set up right and I managed to cram the wires for the mod-board AND the little logic circuit crap for the single switch uk/us/jap mod, all back into the system and it worked. I was goin good for a while until I brought it into school today for our end of the year senior party. I was playin along no problem at all, except I didn't really stay on any one game for more than 5 minutes... My CDR of Daytona CCE refused to work for some reason... I tried it a bunch of times... but then all of a sudden when I went to play another game... it just didn't do anything.... there was no laser activity... there was no spindle movement... nothing o_O;; it wouldn't do the flying pieces that smack into the screen, it would just automatically bring up the saturn screen (like if you had turned it on with the door open)...then it would go to the cd-player screen and just say "Checking disc format"..........

    I couldn't figure out what the problem was.. I popped the saturn open and tried it without the board, and it worked fine (on all my non-backed up games :p )...I'm just at a loss 'cause I spent freakin' thirty bucks on the thing (or twenty... whichever) and now it doesn't work... and I don't want to keep exposing my original game cd's to any more torment.

    If anyone else has had a problem with the modboard suddenly NOT working, PLEASE let me know...and if you've found a way around it x.x Thanks in advance guys!!
     
  2. mal

    mal Member

    From my 21 pin mod experiment thread:

    It could be that either the power wire or the signal wire has broken at some point. I'd check those first.

    Or you mod may have died. ???
     
  3. MuttFox

    MuttFox New Member

    Crap, mybad. I forgot one other thing in that x.x The square chip on the board gets REALLY hot if you just let it sit there.... I assume it's getting power in that case... either that or it's using somethin from the ribbon cable connector.

    I dunno, I'll check it out later today if I get the chance.
     
  4. Curtis

    Curtis Member

    Sounds like you've got a short somewhere - either on the modboard or in your soldering job. Either way, the board should not be getting hot - it's probably fried by now...
     
  5. mal

    mal Member

    It gets really hot?

    You did connect to 5v rather than 9v didn't you?
     
  6. MuttFox

    MuttFox New Member

    Well it was working beforehand, and then it just stopped...like I said.

    I don't know what the problem is (and I'm not one to screw somethin up usually :p Heck, I even managed to make that Genesis ROM dumper and have it work first thing)
     
  7. Curtis

    Curtis Member

    Connecting the chip to the 9v rail may have enabled it to work for a short time before burning it out. Check (with a multimeter) that it is not connected to the 9v supply.
     
  8. MuttFox

    MuttFox New Member

    No, believe me, it's on the 5v line :p I used the same connector that I power the 3 country mod with.

    I just tried the thing again and its still not workin x.x money down the drain... is there any OTHER 21-pin mod available?
     
  9. Gallstaff

    Gallstaff Member

    You could always get one of those "really common" miracle pass-thru mods that celecia is always going on about. I think it was mentioned somewhere in the buy/trade section...
     
  10. mal

    mal Member

    Muttfox, I think you've just been unlucky.

    If you've checked the soldering and conductivity of both the power wire and signal wire (and they are good) then I guess you've just got a bad mod.

    I don't think that a different style of mod will be neccessarily any different. I've dealt with three 'two wire' mods and haven't had one die yet. The latest one I've bought has had quite a bit of handling and resoldering and still works fine.

    Try getting one from Lan-kwei. They are nice and cheap.

    Nice spelling Gallstaff.
     

Share This Page