¿Jap? broken Mega CD

Recently I've bought a jap mega cd. Well, really I don't know if it's jap, because it does not run with my jap megadrive, saying "this is a pal-southeast asia system" with the typical cyan screen with black letters. But it has the jap "Mega CD" logo on the front of the system and it only works if system is 50hz and jap language.

Anyway, when I made it to "work", it only shows the first frame of the bios intro. It hangs automatically, so I only see the "Sega 1991 Bios 1.00" text and the blue sky with clouds. With the ready light on on the front of the system. And nothing more happens.

Who sold it to me said that the cd-reader was broken, what I thought I should be able to see the bios at least. But I can't.

My problem is that I can't open that stupid system because when I unscrewed all the screws I found that the piece of the connector to the megadrive does not let me to open the system. How the hell can I slide/push/destroy (better one of the first 2) that thing so I can open the system and take a look?

Thanks!
 
I managed to open it, I forgot 2 screws on the piece that was making things difficult.

So now, if someone thinks about something that could be happening so it does not want to work... help is welcome!
 
Well, and now I tried it with a PAL (english, 50hz) mega drive and it does the same, so I don't know really what version should it be, but it has the japanese mega cd logo on the front along with sega.

I can't go further that a frist frame of the bios...
 

Arakon

New Member
that's what happens when the bios can't see the segacd at all. it's the same as if you tried to load the segacd bios to a flashcart.

could simply be a bad contact on the bios chip.
 
If it's that, it has an easy solution?

Do you think that unmounting all connections and mounting them all again can do something right? The bios is the EPR-14563H chip removable from the slot?
 
Top