• Rise from your gwave!

All working ok!! New beta!!

Discussion in 'Saturn Dev' started by Denis, Nov 27, 2001.

  1. Denis

    Denis New Member

  2. Denis

    Denis New Member

    please, don't forget that there is no background in "attract" mode. Insert coin, press start 1p and wait :)

    Also, screenshots on site is little glithces (seems that they badly converted from bmp2jpg)
     
  3. TakaIsSilly

    TakaIsSilly New Member

    Could anybody check if this version runs on a real Saturn? Minde didn't, so...
     
  4. Shentar

    Shentar New Member

    Well, I tried it. It kinda worked. The swap trick was acting very strange with it. It would get to the point where it would drop in speed, but then it would try reading something on the inside of the disk over and over, until I swapped disks, and then it went to the outside of the disk. I so then I swapped back when I was supposed to. And it loaded. I got a black screen with some text on it, and it said press start to continue, so I did that. Then I was on a screen that had a bunch of stuff on it, and I ended up turning it off because it didn't go past that screen for a while (I pressed all the buttons, nothing happened, I probably just didn't wait long enough). I wasn't able to get it to work again, it would always freeze on the Sega screen. Probably just because I can't get the swap trick to work often. You might want to wait and see if somebody that has their system modded can try it.

    (Edited by Shentar at 3:08 pm on Nov. 27, 2001)
     
  5. TakaIsSilly

    TakaIsSilly New Member

    Well, the dificulty to swap is because of the small size of the ISO... I'll make a version with a huge dummy later on(something that compresses well, like a huge blank file).

    The real emulation starts after that error (basicly the whole screen gets a load of greenish tiles... I belive it's my fault, and will look into that...
     
  6. IceDigger

    IceDigger Founder Staff Member

    Can I get your permission to post this news on the main page and also to upload the emulator/source to the SX ftp for all to see?
     
  7. Shentar

    Shentar New Member

    I think the screen I ended up on was the screen you're talking about, with all the greenish tiles. Though from memory I would say they were more blueish. :p
     
  8. Denis

    Denis New Member

    To TakaIsSilly.

    Do you think it's because ClsFast? Maybe try without clearing memory?
     
  9. TakaIsSilly

    TakaIsSilly New Member

    I'm almost sure it is(it's not needed anymore, anyway), but I can't do a version right now.

    If not, it's a bug of the tile converter... The best way to check if the error is mine would be to burn a version of your original emulator and check if it works that way.
     
  10. mal

    mal Member

    I'm planning on giving this a go on my modded Saturn as soon as I get my burner back. Just which one is it you want tested? The 'safe' version or the 0.5beta?

    I think you mean the 'safe' one.

    Way to go with this program. You're emulating one of my all time favorite games! :)
     
  11. Denis

    Denis New Member

    Cant burn cd myself right now :(

    But I uploaded so called "SAFE" version (no ClsFast, included cinit function) to site.

    http://phemusat.tripod.com

    Will wait for reports :)

    http://phemusat.tripod.com
     
  12. Shentar

    Shentar New Member

    I'd test it if I weren't down to my last 5 CD-Rs.
     
  13. Shadow Sonic

    Shadow Sonic New Member

    denis im testing it now. ok
     
  14. TakaIsSilly

    TakaIsSilly New Member

    Good luck Sonic ^^. Denis, you're _this_ close to have the first fully flegged non-comercial emulator for Saturn ^^;
     
  15. Shadow Sonic

    Shadow Sonic New Member

    nut'in but dem tiles...
     
  16. TakaIsSilly

    TakaIsSilly New Member

    I'm stomped. Must be something else... what, i don't know...
     
  17. Denis

    Denis New Member

    Thank you all for help and support!

    Btw, this emulator never exits without great help of TakaIsSilly.

    Seems that there is now the hardest part - find the bug which crash the emu on real saturn. Btw, maybe try to contact Charles Doty - maybe he can't look at it too...

    To TakaIsSilly, the SAFE version also used 320x224 resolution (i.e. standart), so it's possible that bug is caused from direct writing to vmem (i.e. when we stores tiles and color? Becasue it's (i mean safe version :)) even not use ClsFast function...

    I think, the only way to find what causes bug is to remove step-by-step functions which are directly acceses vmem.
     
  18. TakaIsSilly

    TakaIsSilly New Member

    I'm down with a cold right now, I dunno if I can feel up to the task of programming... But you try this. Before the routines, do a SlTvOff() and after them, do a SlTvOn() ... this should stop the SGL GFX interrupt routine from accessing the video memory.
     
  19. TakaIsSilly

    TakaIsSilly New Member

    All the regulars of this board ran away, it seems...

    I'm feling better, so i'll debug this... maybe under GiriGiri I'll find the problem :)
     
  20. ExCyber

    ExCyber Staff Member

    I didn't run away, but I'm not really qualified to debug SGL stuff; the only times I try are when nobody else seems to be able to, and I just look for stuff that's obvious from the function reference...
     

Share This Page