Can somebody help me please!!!

chinagon

New Member
Please, Please, Please, Please, Please can somebody help me? I've just downloaded satourne from this site, because I scratched my my Shining Force 3 disk, and I desperately want to play it. Anyway the bloody thing doesn't run. I got the ASPAI driver, but it still just gives me error messages. Does anyone out there know how I can make it work, PLEEEAAASSSEEE!!!!!!!
 

mal

Member
Dude, take a breath. You're not going to die if you can't play this game...

Out of interest, how is using an emulator going to help you use a scratched disc?

Why not make a copy of it and use the swap trick to get it to boot?

If you're set on using an emulator, it would probably be best to start with a newer version. Set it up as the readme suggests and then if you have any problems, tell us just what the error messages you get are. Details are important as my mind reading isn't working very well today.
 

alucardgar

New Member
The speed of the emulation won't help if you want to play. I think that the emulators are usefull to test images before burning, nothing more..... ;)
 

alucardgar

New Member
Well chinagon, now it's my time to have problems with it.

It's giving me the message: Unknown opcode : SH2 blahblahblahblah......

Does somebody knows what's wrong? :ph34r:
 

mal

Member
I guess that the game you are using tries to use an SH2 opcode that isn't emulated yet? :huh

Does it do that for all the games you try or just some?
 

alucardgar

New Member
Originally posted by mal@Oct 14, 2003 @ 02:36 AM

I guess that the game you are using tries to use an SH2 opcode that isn't emulated yet? :huh

Does it do that for all the games you try or just some?
I had tried only with some games (3 I think) and all of them had this problem...

Tell me a game that works for sure and I'll try it.
 

mal

Member
I have no idea.

I've never actually used Satourne. I own several Saturns and hence have no need to.
 

Runik

Staff member
All opcodes are emulated in Satourne. The problem isn't from here.

2 choices :

1- The bios isn't loaded

2- The game is started but jumps to a memory location that isn't populated yet.

Did you see the Sega license logo ? If so, then your game started, but isn't supported yet.
 

alucardgar

New Member
I don't even see the Sega licence logo Runik, when I clik on "run" the message apears...

And mal, I have a Saturn too but I'd like to test the games I get before burning....
 

M3d10n

New Member
Well, another option is installing some virtual CD drive, mouting your images, and testing them with SSF.

Preferrably, a 6.x version of SSF, because I heard the compatibility changed in the 7.x versions (I couldn't test, because me Duron doesn't have SSE).
 

mal

Member
Considering the difficulty you're having perhaps it's better to just 'risk' a CDR without testing the game first. ;)
 

Runik

Staff member
I don't even see the Sega licence logo Runik, when I clik on "run" the message apears...

It's typically what happens when the saturn bios isn't loaded.

Try this : Options-> Other options -> Choose saturn bios
 

alucardgar

New Member
Try this : Options-> Other options -> Choose saturn bios
Well, I'm doing this, maybe I have a bad bios.....

Considering the difficulty you're having perhaps it's better to just 'risk' a CDR without testing the game first.
I end up doing this. But It would be cool to run the emulator....

_____________________________________________________________________________________

Well , it's working now. It was a stupid error, I wasn't loading the stv bios, and it didn't work without it....

I got no sound with it, does it emulate sound or not?
 

Runik

Staff member
No sound in Satourne yet.

I started playing with directSound a bit, and when I will get rid of problems I have with the 68000 I'll try to do something on this side.

And the results will benefit both emulators ;) (the scsp is a real bitch to understand ...)
 

Johnny_Big

New Member
Yes. it does, but the sound for shining force III isn't the same...the game runs well and the music is great, but there some effects missing in the music and the game has a slowdown when you make a magic or special attack...
 

M3d10n

New Member
GiriGiri's sound emulation is very limited. It doesn't support the Saturn's buffer effects fully, most notably the fade effects, so all synth music sounds strange, more midi-ish. Shining Force 3 and Panzer Dragoon Saga audio sounds almost the same, because those games pretty much use several channels playing different pitch-swifted PCM files, but it's FAR less rich, since the notes won't smooth interpolate and there are no reverb/fadeout effects.

Radiant Silvergun's music becomes a garbled mess that eventually stops playing, prolly because of the nasty sound code Treasure might've developed... that game might even use some FM.
 
Top