Dead 32X??

Mr. Moustache

New Member
I've been desperately trying to get my 32X to work, with no success in any way shape or form. And now, to explain the problem...

I have 2 32X's(one is missing somewhere), I've lost 2 of the electromagnetic shields(the longer ones). I've asked around and can't find them unless I go and buy another 32X. But from what I've heard, you don't need them to hook it up to a model 2 gen.

Anyways, every time I power it up I get nothing but a black screen. I've tried both genesis and 32X carts, but I got the same results with both. The genesis works fine by itself, so I know that's not the problem. And the 32X is, comsmetically at least, in mint condition. I've checked connections, tried resetting it more than once, and I'm just completely stumped on what's goin on.

Also noteworthy, the carts feel like they aren't going in all the way, both genesis and 32X. If you jiggle em they move back and forth quite a bit. I've checked and double checked to make sure they were in as far as they can go. So again, I'm stumped.

If anyone could help out it'd be much appreciated.
 

TheXev

New Member
I have a very similar problem with my 32X, but it seems easily remedied by taking it completely apart, and then putting it back together. Don’t ask me WHY… it just works after I do that. O_O;
 
Top