SATURN DOWN!!! SATURN DOWN!!!

Shitface

Member
GUYS!!! i think i just killed my saturn!!!! DAMN MAN!! Ok, i got my mod chip in the mail today. Followed instructions on installing it. When i go to test it out, the saturn screen doesnt load up normaly, it just shows up, drived doesn't spin, and then it goes to the cd door open screen and makes like this helicopter noice and the little boxex are huge and red. SO i tried to take te mod out and the stupid blue wire came off the pin. So i completely took out the mod. And put the ribbon back in. Now the drive doesn't spin and try to read cds!! Did i fry my saturn!?!?!
 

slinga

Member
Remove and re-seed all the ribbon cables (without the mod). See if your saturn will boot now. Something similiar happened to me, but I bent the pins on the ribbon cable (don't ask how, I don't even own a modchip...).
 

Shitface

Member
SLINGA!!! YOUR MY NEW GOD!!!!! IT WORKS NOW!!! PHEW!! i just bought a slew of shiznit off ebay and it comes tomarrow. Thank you, the mod will have to wait. Is there any stores like computer stores that will solder for you? That would help, the stupid 64 pins are to small and my dads soldering iron sucks major caca.
 

klakalou

New Member
lol, my dads solder sucks too. i never took the chance of modding my sat, in fine using the swap trick(though i did go through 2 5-in-1 carts)
 

IBarracudaI

New Member
SegaSquad, have you tried mal's A+B method?

You wont have to solder the blue wire (for the sync signal) to the IC on the cdboard... check the sticky thread on the Saturn Section...

Edit: Forget this post... I've just checked your other thread... :smash
 

Shitface

Member
Yeah, i read the thread after i tried the pin. Stupid me!
Im going to do the a and b method in a few minuts actually. So wish me luck that i don't screw up the chip!
 

IBarracudaI

New Member
Just be nice with it


And if it happens to the cd drive not spinning try pushing the mod towards the center of the console.. my modboard doesnt work well if it isn't pushed left.. contacts probs..
 

mal

Member
Look at the picture with the seventh post in this thread.

At the bottom left of the mod, there's a solder bridge (blob) that joins a common point to a point marked '0014'. The alternative point is marked '0019'. No Saturn that I've ever modded has needed the 0019 bridge in place.
 

Shitface

Member
I can get my mod to read audio from the cdr and originals. I read the thread you showed. My 0014 bridge is solderd. So what do i do now? Is it cause i have a lik-sang and a 64 pin saturn? is there no hope!?!
 

Shakey Jake33

New Member
Originally posted by mal@May 31, 2003 @ 10:09 PM

Look at the picture with the seventh post in this thread.

At the bottom left of the mod, there's a solder bridge (blob) that joins a common point to a point marked '0014'. The alternative point is marked '0019'. No Saturn that I've ever modded has needed the 0019 bridge in place.

Funny you should say that, mine needed it. Just did it today in fact.
 
Top