Sega Saturn Patcher

Sega Saturn Patcher Discussion Thread 1.91 BETA

Knight0fDragon

Patron Supporter
Knight0fDragon updated Sega Saturn Patcher with a new update entry:

Update to 1.91 BETA

Sega Saturn Patcher V1.91 (Beta for 2.0)

(C) 2021 Knight0fDragon - Knight0fDragon@gmail.com

If you would like to say thanks and offer a donation, I accept only PayPal
at knight0fdragon@gmail.com

Thanks to everybody over at SegaXtreme and Sega Saturn Shiro, along
with various people communicating with me on the side,
working out all of the kinks with this program.

Special thanks to dibz' and the rest of SegaXtreme.met for providing a home for resources and...

Read the rest of this update entry...
 
It seems that Version 1.3 of the patcher actually works much better than the recent one. It Definetly is the better one, at least for Dracula X.
 

Knight0fDragon

Patron Supporter
Yes, sorry. 1.91 BETA is well, a beta haha.

I think I said somewhere that you should try other versions since, the permissions were giving me issues across different versions of 10.
 

Knight0fDragon

Patron Supporter
I need to get it out publicly. Wasn't expecting all of this to roll out this fast. For now, you can change SSP to ZIP, go into the file, and change the version.txt number inside of it. I will get a 1.91 version up later on tonight.
 
Hello!
I'm facing trouble to make it work on Windows 7 x64...

The patcher runs fine, recognize the game format (*.BIN) and recognize the patches too (tests with Grandia and Death Mask).

When the program start the patching process, it freezes in a couple seconds and return the message "SegaSaturnPatcher.exe stops working".

Any ideas what is wrong? Or it don't work under Windows 7?

I've tried to clea the temp folders and reinstall .Net SDK 5, without success...

EDIT: I made the *.BIN images with IMGBurn and my original discs twice... tried CCD format too....
Thanks!
 

Attachments

  • screen2.PNG
    screen2.PNG
    97.5 KB · Views: 21
  • screen1.png
    screen1.png
    76.2 KB · Views: 21
Last edited:

Knight0fDragon

Patron Supporter
I would check if your windows temporary folder is clean and you have space. Also, I strongly recommend not to use the CD option in that build, and instead use the CD Image option if you have it.
 
I would check if your windows temporary folder is clean and you have space. Also, I strongly recommend not to use the CD option in that build, and instead use the CD Image option if you have it.
Yeah, I did it again (clean the temp and prefetch folders)... tried to update the Windows, restarted my machine... tried it in another desktop, no game for me...
 
I am also trying to patch Gradia 0.96 Disc 2 on Windows 11. I load the same image I always use it loads. I load the patch. I ask it to create an image and it spins and closes. I have used the patcher many times including for Bulk Slash, but it's not working for Grandia 0.96.
Tried with admin privileges and even in compatibility mode for almost everything. It does not work for Grandia 0.96.

I did notice that nothing shows up in the "Meta" and "ReadMe" sections of the patcher when loading Grandia 0.96.

The image attached shows what happens when I load Grandia image and then the patch with the blank Meta and Read Me sections.

grandia.png
 
I've also been having some difficulties using the patcher. I'm attempting to create a patch for Wipeout XL that replaces the music and some of the in-game text.

I'm able to create an ssp file with the most recent version, but the patcher crashes while applying it. Some older versions will patch successfully, but the resulting disc images always fail to load on both emu and hw (they'll go past the sega logo and get stuck on a black screen). I've tried quite a few things to work around it (different disc images, versions of the patcher, different machines, etc.) but haven't had any luck so far.

I've used the patcher before for Grandia/Dracula X/Bulk Slash and didn't run into any issues, so I'm wondering if I'm doing something wrong with the patch creation or maybe it just doesn't play nice with this particular game.

EDIT: I should probably also clarify that the game does work correctly with the modified files when they're applied manually.
 
Last edited:
Top