• Rise from your gwave!

bad memory?

Discussion in 'Genesis/Mega Drive' started by sparky, Nov 15, 2001.

  1. sparky

    sparky New Member

    last night my wife tried playing sonic cd, it booted up fine then got a screen that said your internal ram is not initialized, use the control panel to initialize your ram. she couldn't get any farther. so i tried to go to the control panel but i can't get it up. so i put lunar 2 told it to continue and all my save slots were gone. so then i tried dark wizard. but it couldn't even find my backup cart. so who think the internal ram in my cdx is fried?? or is there a backup battery that might need replacing??
  2. JCTango

    JCTango New Member

    maybe you need to format it
  3. sparky

    sparky New Member

    but how, i can't access the control panel. i hit the start button when it boots up that would normally take me there, but now it just says please wait till either it loads the disk or just sits there and says no disk. i put in a music cd and it brings up the cd player. but the memory options are not there. am going to take it apart tonight to see if it has a battery i can replace to see what happens
  4. IceDigger

    IceDigger Founder Staff Member

    with a game cd in the drive, hit B at the bios screen, not start.

    as for the battery, it's rechargable.
  5. Curtis

    Curtis Member

    Don't forget, even recharagable batteries die eventually. After a while, they just no longer hold a significant charge (You might as well be trying to charge a resistor). You've gotta be careful because a dead recharagable cell can overheat and either explode (unlikely) or leak muck all over the PCB (much more likely).

    Either of which is a bad outcome...

    EDIT: spelling

    (Edited by Curtis at 1:53 am on Nov. 16, 2001)

Share This Page