• Rise from your gwave!

Problem with Metal Slug and Action Replay Plus 4M

Discussion in 'General Tech Help & CD Burning Help' started by Eidolon_NG, May 30, 2016.

  1. Eidolon_NG

    Eidolon_NG New Member

    Hi y'all,

    I am experiencing a strange problem with Metal Slug's "attract mode" (demo mode when waiting at the title screen and doing nothing) and my newly acquired Action Replay Plus 4M cartridge.

    See this video:

    I tried the Saturn Kamasutra - meaning, I tried every possible (well, at least a dozen) angles of how I can insert the Action Replay in the Saturn cart slot. Nothing helps.

    Do I have a faulty Action Replay?
    Do I have a faulty Metal Slug CD?
    Is this is known problem of Metal Slug's attract mode ("bug")?
    Last edited: May 30, 2016
  2. Is this a backup copy of metal slug or an original? Maybe its a bad burn/dump?
  3. Eidolon_NG

    Eidolon_NG New Member

    It's an original, and the CD looks fine (no scratches or such) so I rule out a CD read problem...
  4. Bizarre, if you have a modchip installed or are comfortable using the swap trick (do so at your own risk of course :p) make a backup and try patching the region and booting the game without the cart and see it still does the same thing.
  5. Eidolon_NG

    Eidolon_NG New Member

    Why should I do that? I have a "modded" PAL Saturn which is 50/60Hz and DE/JP/US switchable.
    Why should the weird graphics problem be related to the region code of the Metal Slug CD?
  6. I didn't know you had region switches installed on your saturn. I assumed you were using the Action Replay to get around the region lock. You probably should've been more specific about your setup in the OP especially considering you have multiple saturns :p. I was thinking maybe there was some sort of compatibility issue with the AR cart and that game, not the region code per se. So does this occur when you boot the game without the cart?
  7. dibz

    dibz Staff Member

    No idea on the PAL Saturn. For what it's worth I used to play Metal Slug all the time back in the day, and I definitely had the same cartridge. Mine was a burned copy w/ a mod chip though.
  8. Eidolon_NG

    Eidolon_NG New Member

    Ok right, I just naturally assumed that the problem is not related to a 50/60/region issue due to the fact that the rest of the game works.

    As it is Metal Slug, obviously the game cannot even be booted without a RAM cart. All that comes up is a warning screen.

    Well, let's close this thread. I guess I need a known-to-be-working Saturn as reference device to find out if the issue is related to my AR cartridge or the Saturn itself. It was just a try if anyone had seen the same behaviour as in the video and may have a solution right out of hand.
  9. Perhaps there's an action replay code floating around somewhere that fixes this (if its a known compatibility issue). If not it might just be a scuff on your disc
  10. Eidolon_NG

    Eidolon_NG New Member

    The disc is flawless. So there is NO other way than to wait until I find a known-to-be-working Saturn to crosscheck if my AR or the Saturn is the problem.
  11. Thales Peres

    Thales Peres New Member

    I've been experiencing the same kind of problem with my AR, and for me, it happens during gameplay, if I pause and leave it for a few minutes, when I unpause... BOOM! all glitchy just like on your video! As far as I know, everything is OK with my saturn (NTSC model 2)

    It also happens on Groove-on-Fight, with lots of strange behavior happening with the same conditions... pausing and after a few minutes, unpause, and glitchy behavior mostly when changing characters during fight
  12. Are either one of you using any sort of cheat codes or just strictly using the carts for ram etc?
  13. Eidolon_NG

    Eidolon_NG New Member

    @Thales Peres thanks for sharing. @SegaSaturnShrine I for one use it strictly for RAM cart, no cheats.

    So it seems either both our AR have a Saturn cartridge port contact problem, both are faulty, or AR's RAM mode is faulty (in the sense that it is not working 100% like the one in the RAM cart which was packaged with Metal Slug).

    I wish I had not bought the AR, but a Metal Slug full package with CD+RAM cart. Then I'd know for sure what the problem is, but I guess this would be the most expensive way to narrow down the problem...
  14. dibz

    dibz Staff Member

    Now I'm rather curious. I haven't tried mine since before I was married, so 14+ years ago now.

    Maybe I'll hook up the ol' saturn tonight and see what happens.
    SegaSaturnShrine likes this.
  15. Thales Peres

    Thales Peres New Member

    That can't be the case on my side because I have Pseudo Saturn Kai flashed on my AR... which doesn't have the codes functionality yet
  16. Oh okay, Idk then perhaps just some sort of data clash due to the hardware inside the cart itself messes with that particular game. Outside of that, i'm totally stumped
  17. Thales Peres

    Thales Peres New Member

    I made some small videos: (One handed gameplay + glitched game... lol)



    The more time paused, more corrupted it gets when unpaused: here you can only see blocks of solid color instead of sprites:

    Last edited: Jun 10, 2016
  18. That is really bizarre for sure. There must be some major compatibility issue with this game and the AR carts for whatever reason. I would imagine using an official RAM cart would get around this problem...
  19. Torico

    Torico New Member


  20. antime

    antime Extra Hard Mid Boss

    Red Ring Rico likes this.

Share This Page