Trying to get 1360x768 TV out (HDMI) on Linux

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

slinga

Member
Joined
Apr 17, 2001
Messages
1,063
Points
36
Age
35
Website
Visit site
Hey all,

I'm stumped trying to connect my MythTV box running SuSE 10.2 to my Samsung LNS-4051D LCD TV (http://www.amazon.com/Samsung-LNS4051D-Wide-Integrated-Tuner/dp/B000ELOQS2). The Samsung's monitor says its optimal resolution is 1360x768. My MythTV box has a Geforce 6600 and I connect it to my TV with a DVI->HDMI cable. I have the NVidia drivers installed and they are functioning properly.

Mucking around with my xorg.conf I can get a maximum resolution 1280x720 which I believe is 720P. The display looks pretty decent but it's cut off from all four sides.

I tried a number of custom modelines but I'm stumped. My manual lists a ton of figures but I think I'm calculating it wrong. Here are the values from my TV manual:

Resolution: 1360x768

Horizontal Freq: 47.712

Vertical Freq: 60.015

Pixel Clock Freq: 85.800

Sync Polarity (H/V): +/+
With all this info it should be a cinch to calculate a proper custom modeline, but I can't seem to get it to work. Thanks in advance.

My xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig

# nvidia-xconfig: version 1.0 (buildmeister@builder26) Fri Dec 15 10:40:27 PST 2006

# /.../

# SaX generated X11 config file

# Created on: 2007-01-13T19:50:43-0500.

#

# Version: 8.1

# Contact: Marcus Schaefer <sax@suse.de>, 2005

# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

#

# Automatically generated by [ISaX] (8.1)

# PLEASE DO NOT EDIT THIS FILE!

#

Section "ServerLayout"

Identifier "Layout[all]"

Screen "Screen[0]" 0 0

InputDevice "Keyboard[0]" "CoreKeyboard"

InputDevice "Mouse[1]" "CorePointer"

Option "Clone" "off"

Option "Xinerama" "off"

EndSection

Section "Files"

InputDevices "/dev/gpmdata"

InputDevices "/dev/input/mice"

FontPath "/usr/share/fonts/misc:unscaled"

FontPath "/usr/share/fonts/local"

FontPath "/usr/share/fonts/75dpi:unscaled"

FontPath "/usr/share/fonts/100dpi:unscaled"

FontPath "/usr/share/fonts/Type1"

FontPath "/usr/share/fonts/URW"

FontPath "/usr/share/fonts/Speedo"

FontPath "/usr/share/fonts/PEX"

FontPath "/usr/share/fonts/cyrillic"

FontPath "/usr/share/fonts/latin2/misc:unscaled"

FontPath "/usr/share/fonts/latin2/75dpi:unscaled"

FontPath "/usr/share/fonts/latin2/100dpi:unscaled"

FontPath "/usr/share/fonts/latin2/Type1"

FontPath "/usr/share/fonts/latin7/75dpi:unscaled"

FontPath "/usr/share/fonts/baekmuk:unscaled"

FontPath "/usr/share/fonts/japanese:unscaled"

FontPath "/usr/share/fonts/kwintv"

FontPath "/usr/share/fonts/truetype"

FontPath "/usr/share/fonts/uni:unscaled"

FontPath "/usr/share/fonts/CID"

FontPath "/usr/share/fonts/ucs/misc:unscaled"

FontPath "/usr/share/fonts/ucs/75dpi:unscaled"

FontPath "/usr/share/fonts/ucs/100dpi:unscaled"

FontPath "/usr/share/fonts/hellas/misc:unscaled"

FontPath "/usr/share/fonts/hellas/75dpi:unscaled"

FontPath "/usr/share/fonts/hellas/100dpi:unscaled"

FontPath "/usr/share/fonts/hellas/Type1"

FontPath "/usr/share/fonts/misc/sgi:unscaled"

FontPath "/usr/share/fonts/xtest"

FontPath "/opt/kde3/share/fonts"

FontPath "unix/:7100"

EndSection

Section "Module"

Load "v4l"

Load "dbe"

Load "glx"

Load "type1"

Load "freetype"

Load "extmod"

EndSection

Section "ServerFlags"

Option "AllowMouseOpenFail" "on"

EndSection

Section "InputDevice"

Identifier "Keyboard[0]"

Driver "kbd"

Option "Protocol" "Standard"

Option "XkbLayout" "us"

Option "XkbModel" "pc104"

Option "XkbRules" "xfree86"

EndSection

Section "InputDevice"

Identifier "Mouse[1]"

Driver "mouse"

Option "Buttons" "7"

Option "Device" "/dev/input/mice"

Option "Name" "Darfon RF Combo Mouse"

Option "Protocol" "explorerps/2"

Option "Vendor" "Sysp"

Option "ZAxisMapping" "4 5"

EndSection

Section "Modes"

Identifier "Modes[0]"

Modeline "1360x768@60" 84.73 1360 1424 1568 1776 768 769 772 795 -HSync +Vsync

# Modeline "1360x768@60" 84.98 1360 1392 1712 1744 768 783 791 807

# Modeline "1360x765@60" 84.14 1360 1392 1704 1736 765 780 788 804

# Modeline "1360x768" 85.800 1360 1400 1534 1800 768 771 781 794

ModeLine "1024x768" 64.1 1024 1080 1184 1344 768 769 772 795

ModeLine "1024x600" 49.0 1024 1064 1168 1312 600 601 604 622

ModeLine "800x600" 38.2 800 832 912 1024 600 601 604 622

ModeLine "768x576" 35.0 768 792 872 976 576 577 580 597

ModeLine "640x480" 23.9 640 656 720 800 480 481 484 497

EndSection

Section "Monitor"

Identifier "Monitor[0]"

VendorName "--> VESA"

ModelName "1024X768@60HZ"

UseModes "Modes[0]"

DisplaySize 862 485

HorizSync 45.0 - 48.0

VertRefresh 58.0 - 63.0

EndSection

Section "Device"

Identifier "Device[0]"

Driver "nvidia"

VendorName "NVidia"

BoardName "GeForce 6600 GT"

Screen 0

EndSection

Section "Screen"

Identifier "Screen[0]"

Device "Device[0]"

Monitor "Monitor[0]"

DefaultDepth 24

SubSection "Display"

Depth 15

Modes "1360x768@60" "1280x720_60" "1024x768" "1024x600" "800x600" "768x576" "640x480"

EndSubSection

SubSection "Display"

Depth 16

Modes "1360x768@60" "1280x720_60" "1024x768" "1024x600" "800x600" "768x576" "640x480"

EndSubSection

SubSection "Display"

Depth 24

Modes "1360x768_60" "1920x1080_60i" "1280x720_60" "1024x768" "1024x600" "800x600" "768x576" "640x480"

EndSubSection

SubSection "Display"

Depth 8

Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"

EndSubSection

EndSection
 

gravitone

New Member
Joined
Nov 21, 2001
Messages
6
Points
1
Website
www.troll.net
slinga said:
Hey all,

I'm stumped trying to connect my MythTV box running SuSE 10.2 to my Samsung LNS-4051D LCD TV (http://www.amazon.com/Samsung-LNS4051D-Wide-Integrated-Tuner/dp/B000ELOQS2). The Samsung's monitor says its optimal resolution is 1360x768. My MythTV box has a Geforce 6600 and I connect it to my TV with a DVI->HDMI cable. I have the NVidia drivers installed and they are functioning properly.

Mucking around with my xorg.conf I can get a maximum resolution 1280x720 which I believe is 720P. The display looks pretty decent but it's cut off from all four sides.

I tried a number of custom modelines but I'm stumped. My manual lists a ton of figures but I think I'm calculating it wrong. Here are the values from my TV manual:

With all this info it should be a cinch to calculate a proper custom modeline, but I can't seem to get it to work. Thanks in advance.

My xorg.conf
Not surprising. HDMI inputs usually only accept a smal list of resolutions/refresh rates. Usually only the PAL/NTSC interlaced and progressive resolutions + 720p, 1080i, 1080p. Any other resolutions such as 1360x768 are usually only supported through a DVI port if available or through the VGA port.
 
Top