Back again.. need help w/ TWO Saturn mod questions

MuttFox

New Member
I had posted here a while back when I had first modded my Saturn and Nomad both with a single switch/3-country modification, I felt I had something to offer to the whole community because at the time I had been all willing to make a huge walkthrough on how to do it and everything, blahblahblah...but I lost interest...

NOW though, I'm back and asking for help on my Saturn with mod board... eh, heh-heh.... when I first got the chip way back a year or so ago, I installed it the way playthegames.com had shown.. worked no problem. Was using for a month or two until one day it just stopped working. Poof. THat's it. Stopped working. I didn't do anything weird to it, I was playing one game then turned the system off and wanted to play another, when I put it in I got the no loading animation and green cubes with the "checking disc format".

Now, I have literally tried EVERY combination of things with this chip... 0014 and 0019, a + B or a + chip pin, power from the power pin on the powersupply or from the pin on my little board for the country mod... turning the cable around.... and all of these mixed with each other... nothing. I have one of the last models (or I assume last run anyway) built in Feb 97.. A jvc cd mechanism and board, 32 pin chip, round buttons, 4 pin power supply..all in all, a very clean looking model inside. The mod chip was a lik-sang chip (the "crappy" blue one)...The other thing I noticed about the chip is the fact that the little square ic in the middle of it gets REALLY hot o_O

I should just look into getting another modchip somewhere, shounldn't I? I guess it just means that my mod chip is dead doesn't it? (also, I want to note that WAAY back when I initially tried doing a country mod to my saturn, it kinda didn't like the fact that i ...... changed the country switches while the thing was ON, and it stopped working for 5 months until, one day, i was sitting there playing my new [older version/model though] saturn and I said "Hmm, i wonder if it would work now for any strange reason.." so just for sh^ts and giggles, i put it together and, lo and behold, it worked like nothing ever happened o_O )

Any my other mod question was... has anyone ever attempted to actually OVERCLOCK the saturn? specifically any of the graphics processing chips, merely for either higher resolution or a better frame rate? I know I'd like to play my Wipeout 2097 (geez, you guys have WEIRD Saturn game boxes in Europe, btw o_O ) at a frame rate a little higher than like FIFTEEN or something >.<;;;
 

Curtis

Member
I'd say your chip is dead. Check to see that you don't have any shorts on any of the pins, but I wouln't hope for much. If you buy another board also check the pins of the power supply to make sure you are using 5v, not 9v.

AFAIK no one has tried to overclock a Saturn, but I can't imagine it would be easy. There would be all sorts of sync issues with keeping all the processors processing together.
 
Top