Fuzzy Sound on Saturn...

Cloud121

Established Member
Hey gyus, whenever I boot up my Sat, I get all this fuzzy sound. It's done this a lot lately, and that why I haven't been playing my Sat at all. I've tried adjusting the cable, plugging, unplugging, bending up and down, took off the SFC RF Adaptor, plugged the SFC RF Adaptor directly in, as opposed to Sat (as it has been for the past 3 years, plugged directly in to the TV, whereas all others have been going through the Sat one), and channeled the Sat one through the SFC Adaptor. Still nothing. What can I do? I need some A/V Cables....
 

Nadius

Established Member
Reminds me of the days I played my Saturn on a small 13 inch knob tv. If your tv is as old as the one i had, try the fine tuning knob.

Yeah, you should get an A/V cable, i got some off of ebay for like 6 bucks shipped.
 

Alexvrb

Established Member
I only had this problem with a cheap 3rd party xbox component cable. I didn't think they could POSSIBLY screw up building a cable that bad, especially not in those quantities. Generally a cable is just a cable, without tremendous differences, but man... The sound and video signals would interfere with each other (not outside interference). Anyway, it just sounds like your RF adapter just kicked Mr. Bucket, but not hard enough to be fatal. www.consoleaccessories.com has it, lots of other places too.
 

Cloud121

Established Member
I couldn't find one of my "No sound" threads, so I'll just post it here.

As you all know, I've had no sound coming from my Saturn for a long time now. First the fuzzy sound from the RF Adaptor, and no sound from the A/V Cables.

Here's the deal:

My teacher at school just bought a Saturn, he wanted to borrow Chirstmas NiGHTS. Letting him, I asked him if he could test me A/V Cables for me. They worked perfectly for him!

So the problem lies with my Saturn! The hell is the deal? What happened to it? How did it happen?

What can I do?

:(
 
Top