Saturn Problems

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

zx7ninja

New Member
Joined
Jul 8, 2001
Messages
80
Points
6
Website
Visit site
Hey guys, I seem to be having a problem with one of my saturns. It still plays all the games just fine, no problems there. But the screen looks all fuzzy, kinda like a little bit of static, Sometimes I get some wavy lines also. It sort of looks like there's some kind of interference. Like when I used to play my Atari and someone turned on a mixer or blender in the other room. LOL

At first I though I WAS getting interference, but checked all possible sources, and could find none. Then I changed the A/V cable. No difference. Then I though it was the input RCA's on the TV. But I wasn't getting the problem with any of my other systems. So I took out my other Saturn and checked to see how that one looked. Perfect. Absolutley gorgeous.

So what do you guys think? Is it the output of my Saturn? That's what it's starting to look like. If so, anything I can do about it? If not, I guess I can just cannibalize it for parts.
 

Nimoy

New Member
Joined
Aug 3, 2001
Messages
23
Points
1
Website
Visit site
I have a small concern with my Saturn, but it has never caused me any troubles. From day one, my Saturn's PSU has always made the left side of my Saturn EXTREMELY hot to the touch within fifteeen minutes of use. This is an unmodded system and was brand new when I bought it. It has always ran reliably for hours upon hours on end, but I have never had anything that gets this hot in my entire life. Is it something I should be concerned with and should I be looking to possibly replace some of the PSU parts?
 
Top