Sega CD Model 1 Broken?

wldguy

New Member
I just went to a used VG store and traded my two non-working SCD Model 2 Units for one SCD MODEL 1 Unit that powers up but does not read the CDs inside the tray. Every time I pop in a CD, it makes a defective very loud “trying to load game” noise. The access light does blink though. The tray itself is also having problems opening and closing. It won’t let me eject the CD unless I hit reset on the Genesis. I've tried cleaning the lens with rubbing alcohol but with no success. I’m thinking that the motor is dead. I did take apart part of the SCD, everything I saw looked fine. I'm also curious to know how to take out the CD drive. If someone could help out I would appreciate it.
 

wldguy

New Member
No, what I meant to say was the CD tray, when opening, opens only halfway then stalls. When closing, it closes halfway then stalls as well. You have to manually push it in sometimes. I went inside the unit and fixed that problem though. I need help with the other problems that are much more serious.
 
It could be a possibly problem with the track on the underside of the tray or the gear on the tray motor. Check and clean the assembly and re-grease the track. That should fix the opening problem.
 

FAKK2

New Member
the gears are the problem take it apart and work with the cd tray, it sounds to me like someone took it apart and couldnt figure out how to put it back together correctly, my model 1 had the same issues til I fixed it.
 

Spartikcus

New Member
Oh such a shame,

Terrible to see such a good machine like this,

Anyways you can send it to Sega-parts.com and they will repair it for you for a flat price of $45.
 
Top