• Rise from your gwave!

Anyone have those old planetweb gamexch Saturn saves?

Discussion in 'Saturn Dev' started by ReyVGM, Jan 7, 2016.

  1. ReyVGM

    ReyVGM New Member

    Didn't work. Tried three games and they all gave error messages.

    Just to test, I used the SS_Backup_RAM_Parser to upload my single Panzer Dragoon 2 save into the bkram file you posted, loaded the game and it worked.
     
  2. cafe-alpha

    cafe-alpha Member

    Arg, sorry ! I didn't had time yesterday in order to perform minimum test on my side.
    Even if it compiles, it doesn't means it works fine ^^;
    I just fixed the problem, you can find updated save data here :
    http://ppcenter.webou.net/divers/20160203_ReyVGM_test.7z
     
  3. ReyVGM

    ReyVGM New Member

    Yep, now it works! Thanks!

    I have a favor. In that saves pack I posted, there's a SaturnSave_6.zip, could you convert the .dat into a bkram? There's a save there I'm interested in (Legend of Oasis).
     
  4. cafe-alpha

    cafe-alpha Member

    Here you are : /divers/20160204_ReyVGM.7z
    It contains save data from other sources, and Dragon Force save isn't included, because too large.

    This .dat file format was already in bkram.bin, so renaming it should do the job, but please use "my" file above in order to verify that everything is OK with my Save Data Manager :)

    edit : removed link to broken test data
     
    Last edited: Feb 5, 2016
  5. ReyVGM

    ReyVGM New Member

    "This .dat file format was already in bkram.bin, so renaming it should do the job, but please use "my" file above in order to verify that everything is OK with my Save Data Manager"

    Sorry I don't quite understand. Renaming dat to bin you mean? And what do you mean by "your" file above? I believe I already confirmed those saves worked for the games I tried.

    *Edit*
    Tried the Magic Knight Rayearth save you included there (I don't know where you got it), and it worked.

    Also tried Legend of Oasis that was in the zip I mentioned before, and I get an error message when loading the game. I don't know if the original save is damaged or if the conversion damaged it.
     
    Last edited: Feb 3, 2016
  6. cafe-alpha

    cafe-alpha Member

    Sorry, my previous post was unclear (I forgot a word ^^; ) :
    > Also tried Legend of Oasis that was in the zip I mentioned before, and I get an error message when loading the game. I don't know if the original save is damaged or if the conversion damaged it.

    Probably some problem on my side. (as usual :D )
    I will retry later, but can you first rename SaturnSave_6.dat to bkram.bin in order to verify that source save data don't show error message ?
     
  7. ReyVGM

    ReyVGM New Member

    I renamed it and it worked! I didn't know with these saves all that was needed was to rename it.
    And yes, the Legend of Oasis works by renaming dat to bin.
     
  8. cafe-alpha

    cafe-alpha Member

    File extension is different (it differs from a dump tool to another), but contents is same :)


    I verified yesterday's bkram.bin problem, and as expected, it was on my side ^^;
    It's fixed (it was due to the usual problem of comparing difference of signed/unsigned data ...), but not tested in depth, so please verify if latest data is OK : http://ppcenter.webou.net/divers/20160205_ReyVGM.7z
    (I added saves from other dumps too, please check if there is save for your favorite game.)

    Once again, thank you for testing :)
     
  9. ReyVGM

    ReyVGM New Member

    Ok, I tried Legend of Oasis, Shining Force 3, Rayman, Metal Slug and they worked.

    Princess Crown gave me an error message. I tried the original dat file, renamed it to bin and the save worked fine. So I guess it's a conversion problem.

    Tried Silhouette Mirage, but it doesn't seem like there's anything unlocked? I don't know where you got that save, so I can't try the original.

    Tried testing Duke Nukem 3D but the game is unplayable on every emu.
     
    Last edited: Feb 6, 2016
  10. cafe-alpha

    cafe-alpha Member

    First, original data comes from here :
    http://www.gamingenterprisesinc.com/DataLink/GameSaves.html -> SaturnSave_1.zip

    And, I found what was going wrong with Princess Crown save : few bytes between offsets 79h~7Fh are not as expected, making the parsing routine incorrectly computing cluster length.
    (If you try to open it with SS_Backup_RAM_Parser, it will incorrectly detect it as a 48 bytes cluster save, which is wrong, 64 bytes cluster length is expected.)

    I have absolutely no plan to repair corrupted saves from my tool, but since Saturn BIOS correctly parses this save as-is, I made few changes in order to compute cluster length by 64 bytes steps.

    Additionally, I merged support for Action Replay save format from ss-save-parser project (special thanks to hitomi2500 :) ), and consequently could copy some saves from an Action Replay cartridge I could dump years ago.

    http://ppcenter.webou.net/divers/20160209_ReyVGM.7z

    Can you verify :
    - That saves imported from SaturnSave_1.zip (Power Slave, Princess Crown, Tomb Raider, Mr Bones) are now OK ?
    - That other saves (imported from Action Replay format) are OK ?

    Thank you :)
     
  11. ReyVGM

    ReyVGM New Member

    I don't know which saves are action replay, so I'll just test the ones I can. Some games aren't properly emulated.

    Mr bones, Princess Crown, Grandia, Sakura Taisen, Torico, Exhumed, Sengoku Blade, Tomb Raider, Vampire Savior, worked

    I tried Radiant Silvergun, Panzer Dragoon 2, Virtua Cop save included there, I didn't get an error message but it didn't seem like it had anything unlocked.

    Tokimeki Memorial did not work, but then again, I might have picked the wrong game since there are like 5 of them and the save name doesn't specify which one it is.
     
    Last edited: Feb 8, 2016
  12. cafe-alpha

    cafe-alpha Member

    [​IMG]
    This validates the last big thing I wanted to implement in Save Data Manager's import feature :]
    (Of course, if you find another problem, I'll fix it, but most of the job regarding saves import is finished I think.)

    Action Replay saves (= other than Power Slave, Princess Crown, Tomb Raider, Mr Bones) are not "professional quality" as USB Data Link's ones, hence probably not finished or with only few things unlocked.
    Some games show "save data is corrupted" screen when save data is corrupted, but not all, so if you have a game showing such screen, please let me know :)

    Here is the full list of the saves in the Action Replay dump I have here :
    >SN3_MATCH01 ( 3072 bytes)
    >GRANDIA_001 ( 3040 bytes)
    >GUYFERD__00 ( 132 bytes)
    >POLICENAUTS ( 3224 bytes)
    >POLICENA_01 ( 3008 bytes)
    >STRIKERS___ ( 2224 bytes)
    >WAN_CHAI_00 ( 305 bytes)
    >TORICO_____ ( 480 bytes)
    >TOKIMEKI_99 ( 52 bytes)
    >TOKIMEKI_01 ( 2628 bytes)
    >DEEPFEAR_01 ( 5184 bytes)
    >VIRTUACOP_2 ( 556 bytes)
    >RADIANT_S_G ( 1868 bytes)
    >PANDRA_ZWEI ( 449 bytes)
    >STEELDOM000 ( 256 bytes)
    >VIRTUACOP_1 ( 556 bytes)
    >NIGHTS___01 ( 1856 bytes)
    >NIGHTS___02 ( 12544 bytes)
    >SNATCHER_03 ( 4064 bytes)
    >SAKURA___01 ( 5708 bytes)
    >SAKURAWARS2 ( 6352 bytes)
    >__EXHUMED__ ( 640 bytes)
    >NIGHTS___01 ( 1856 bytes)
    >SFORCE31_01 ( 12904 bytes)
    >SN_TCOOL_00 ( 29440 bytes)
    All saves didn't fit in a single bkram.bin file, so please let me know if you want one in particular for testing.
    Of course, gathering several saves is possible, but in that case size total must not exceed 30000 bytes.
     
  13. ReyVGM

    ReyVGM New Member

    Good to hear.

    I updated my test post above. Yes, please send all action replay saves in one or two bkram packs. That way I can test that format specifically.
     
  14. cafe-alpha

    cafe-alpha Member

  15. ReyVGM

    ReyVGM New Member

    I'm not going to test all games because I assume that if a good number of them work, then the conversion process should have worked for the others.

    backup1 only has one save, I can't figure out for what game it is. It says sn_tcool

    backup2
    I tested Deep Fear, Grandia and they worked.
    Panzer Dragoon 2 and Radiant Silverfun save didn't have anything unlocked, even the recorded playtime was zero. But I didn't receive an error message at least.

    backup3
    Like the previous test, Sakura wars, Torico, worked. Snatcher and Policenauts work.
    Virtua Cop doesn't seem to have anything unlocked.

    backup4
    Shining Force 3, Exhumed worked. The rest of the saves are repeats or I tested them before already.
     
  16. cafe-alpha

    cafe-alpha Member


    OK, thank you very much ! You deserve your name in Beta Tester's sections of Save Game Manager's credits page ;)

    I don't know too about that mysterious SN_TCOOL_00 save.
    Save comment is "ホンタイヨウ" (本体用 ?), which doesn't helps.
     
  17. ReyVGM

    ReyVGM New Member

    Cool, thanks for the credit :p

    I posted that Japanese text on google and got nothing that resembles anything about a Saturn game.
     
  18. cafe-alpha

    cafe-alpha Member

    Well, I still need to add that credit page ^^; But I will add your nick for sure.
     
  19. cafe-alpha

    cafe-alpha Member

    Madroms just informed about this SN_TCOOL_00 save : it is a save for Sound Novel Tkool 2, aka Sound Novel Tsukuru 2.

    Thank you Madroms :)
     
  20. Jameson

    Jameson New Member

    Ooopsie. The header is corrupted a bit, but nonetheless, there is no (known) save media with a cluster size smaller than 64 bytes. Fixed that one.
    Anyway, you can always override the autodetected settings with a correct ones (provided you know them).
     

Share This Page