Fixing a defective AR4M+

ratfish

Member
Bear with me:


After many attempts at trying to get my "Action Replay 4M Plus" 4-in-1-piece-of-crap to work, all has failed. I'm just about to give up, and after searching all over for means of fixing it, nothing has worked!

The main problem is that it is not working as a memory cart. No copying/saving works.

I've read all the posts I found on the AR4M+, and tried all of the reccomended things to no avail. And, I'm quite aware that many of these PAR+s were "defective" and just don't work, but I though this post might just help? Maybe I'm just crazy.

Here are all of the things that I've tried already:

-cleaning the contacts on the cart

-cleaning the Saturn's contacts (w/a modified NES cartridge cleaner)


-changing the position of the cart in the Saturn

-opened it up and cleaned up messy solder

-tried many times over and over again to copy the save files

-lots of other basic and mind-numbing stuff

Now here's what I'm asking. If anyone has a working AR4M+, and can take a picture of the front and back of the guts, I want to compare mine to it and see if anything is different.

I also have some experience soldering. I know I'm probably being too optomistic, but I want to get this to work. Any help or suggestions are appreciated. Thank you in advance. It's been very frustrating.
 

ExCyber

Staff member
You still haven't answered the $64,000 question:

What happens when you try to do work with saves? Does the interface give you an error message? Does the system lock up? Does Jackie Chan materialize in your room and kick your ass just before you press the button? It's pretty tough to diagnose a problem with no idea of what's going wrong.
 

segaboy7

New Member
I have the same problem. No games reconize my AR4in1 as a save cartrige. I can take saves from the system ram and put them on my 4in1 but when I play that certain game, it does not reconize that the cart is even there. So what good is this extra if no games reconize it
 

antime

Extra Hard Mid Boss
Originally posted by segaboy7@Jan. 24 2003, 12:50 am

No games reconize my AR4in1 as a save cartrige.

The Action Replay doesn't support direct saves, only the Sega cart does that.

So what good is this extra if no games reconize it

You can store the saves of games you aren't currently playing there. Also, you won't lose them if the Saturn's internal battery fails.
 

ratfish

Member
oh yea, sorry excyber about all the confusion. for the last few days i havn't had sleep or food. but i digress...

i understand that the ar4m+ only saves files when in the system bios thingy screen, i know that, but it won't do that, it just freezes when i try to copy a file from internal save to the cartridge when it says "saving. please wait!" it just freezes. it's never worked for me.

sorry for all the pointless points i've made in the last 4 days, and thanks for replying also.
 

ratfish

Member
I havn't tried that yet. ??? The only thing I know that works is the cheat code function. I havn't tried the extra ram feature or the pc link cable (for uploading saves & downloading cheats) either.

So status as of now is:

1. save ram: doesn't work

2. cheat codes: work

3. extra 1M/4M ram: untried

4. pc link: untried

I don't have any games that utilize the 1/4M ram function, so I can't test it yet. I don't have the pc link cable either, but I'm guessing that both of those functions would work (why wouldn't they? the cheat codes work).
 

antime

Extra Hard Mid Boss
Well, since the Action Replay software seems functional and the preprogrammed cheat codes work it seems you can read from the flash rom but not write to it. The flash chips may be damaged or locked up in some way, or in the extreme case the manufacturer may have used the wrong type of flash roms (doubtful, but you never know). I don't really know what you can do with it.
 

ratfish

Member
Hmm...is there any way to "flash" the flash ram, like flashing the bios. Doesn't flashing the bios on the console clear all memory, start from a clean slate, sort of? If so, it would be interesting to try it on the action replay cartridge.

Also, about the chips, this is what I'm seeing:

there are 3 long ones almost in a row on the top

the one on the left has printed on it: PALCE22V10H-25PC/4

9837ABC H

(and a 9 written on when i look at it under a light)

center: P9912SJ

MM74HC245AN

right: ATMEL 9947

ATF16V8B-25PC

Then there are 4 on the left; 2 are Texas Instrument chips (i think) and the other pair have Korea printed on them.

The pair on the right (are these the flash ram ones?) are small squares but have larger rectangular bases.

On them are printed: C010L

0025G

Then on the rectangular bases are printed: EMS-E32

PLCC

The top one has a "7" penciled on and the bottome one has an "8"
 

antime

Extra Hard Mid Boss
Originally posted by SegaFreak@Jan. 24 2003, 11:10 pm

Hmm...is there any way to "flash" the flash ram, like flashing the bios. Doesn't flashing the bios on the console clear all memory, start from a clean slate, sort of? If so, it would be interesting to try it on the action replay cartridge.

Yes, that's what you're doing when writing to the flash memory to store savegames, cheatcodes or when upgrading the software. However, the chips can be put into a state where they can't be programmed anymore, but I don't know if you can get them out of that state through software alone. If you have a Commlink you could try the update software but I doubt it would help. Someone with more knowledge of flash roms can probably help you more.

As for the hardware in the cartridge, it's the same as mine, so no worries there.
 

Supergrom

Member
I just thought I'd let you know that I have this same problem. I try to copy over saves but it just sais saving for forever. Also, one time (after changing the carts postion for a couple minutes) it claimed to have copied the save successfully, so I exited the menu and re-entered but it was gone. And I've never been able to duplicate that ever again. Also note: My extra RAM for other games works perfectly. But I asked this same question a while ago, and the only answer I got was that someone seemed to think it might be my model 1 saturn
 

ratfish

Member
Supergrom, I read that post that you made a while back and I figured out that we do have the same problem with the memory carts. I also have got the "finished" message a few times, but nothing in the cart when I power off and turn back on (or reset).

Also, I tried the cartridge in both a model 1 and model 2 saturn that are both in good condition, so I'm 99% sure it's a problem with the cart and not the Saturn's. So you can rule out that your Saturn's cartridge port is in bad condition.

-by the way, that Snatcher process is just great!
 

Supergrom

Member
hehe, thanks
it was on Artemo Urbina's site (http://junkerhq.net) and was apparrently scanned out of a japanese magazine, and i just broke it up and animated it for my avatar.

and back on topic: hmm, maybe we just got shafted then... oh well, at least the extra ram works since thats what i mostly got it for. Oh and btw, i should be getting a model 2 saturn fairly soon and should be able to test it for myself too, but i wont get my hopes up.
 
Top