Need Help - Saturn not booting ? problem

Ok, here´s the deal.

I think my Sega Saturn is dieing on me, and i don´t like that, AT all.

Here is what is doing.

I turn it up, and the console goes to the Checking Disc Format screen. And stays there on eternal loop. So, i have to open the drive door, close it, to force a new disc check, then it goes into the Checking Disc Format screen, and stays there on eternal loop. Sometimes it checks the disc format, and says there´s 1 track, with 0:00 time, but it doesn´t enable the Start Application button. Other times it checks the disc format, and says there´s 999 tracks total time 999:59, but still doesn´t enable the Start Application button. And other times, it even works.

Now, i could obviously think its something with the laser cannon right ? (And besides, the console is 10 years old). But, after it finds the correct disc, it NEVER fails again. I´ve played through Marvel Super Heroes (example) and it didn´t fail me. I have played several matches on WC98-Road to France, and Fifa98, and never failed, same with pretty much all games.

And it does the same thing with ALL my cds. So i don´t know what to think.

After it recognizes the game, things go sweet and smooth. But before that, its a pain in the arse to make the thing work.

Also, i noticed that when the console is in the eternal Checking Disc Format screen, eventually the disc stops spinning, but the console is still making "acess sounds" and the Acess light (the red one) is still blinking.

I don´t if it matters, but the console is from the very first batch that TecToy released (its american region), black, two oval buttons, with power and acess lights, and i have it back in the day, modded to be region free. (It still doesn´t read cd-r´s), But there´s a switch in the back to change between japanese and usa systems. (Which is reflected by the BIOS default language, btw).

Soooo, any ideas, should i take it to a repair shop ASAP, or what ?

Help me, obi-wan, you´re my only hope.

Edit : I opened it : to see if something simple could solve it, and i didn´t understand SHIT! Apparenly, the system is modded ? But this mod is what ? 10 years old now ? And its different from all the mod chips i found on the web ? I have no clue... literally. All i know, is that i tried to boot cd-r´s once or twice, like.. 6 years ago. And i couldn´t. Now i can´t boot ANY of my discs.

And to top it all off, i left the system in my bed while i was plugging into my tv, and my stupid cat dropped it on the floor. Ever since, i can´t get a disco to go correct not ONE single time..

i am truly depressed. The saturn was my best friend.. for quite some time now.... =( :bawling: :bawling: :bawling:

Pictures :
Is it possible to get better pictures of the insides? Otherwise, you mention it was modded to run backups right? If so, try removing the mod board first. Otherwise, you might be able to get away with replacing the cd-rom. Some of our members sell sega parts yet.

Well, its kinda hard to get more detailed pictures of the insides with my lousy cam. It doesn´t have a macro feature, and the focus range is not that great, but i can try.

Anyway, as far as i know, this console ISN´T modded to read backups. Only modded to play imports. (By the switch on the back) but now that i see a mod board in it. I have no idea.

I bought this console brand new on 24/12/96, so its pretty close to have 10 years on me.

does anyone seem model like this before ? And a modboard like this before ?

I tried to unplug the modboard, and plug the cd cable direct into the console, but i had the exactely same results. So i really don´t know.