saturn not booting

Chris

New Member
I have a saturn that has a mod chip installed. The problem is that the saturn can no longer read data. When ever i but a game in it will play its audio fine, but will not recognize it as a game, is there any way to fix this?
 

Chris

New Member
I have had it in for about 2-4 weeks and they have played the games fine without anyproblems. but for some reason it did not work today. I tried my burn of chrismas nights and it would not work. so i thought maybe its just that game. But then i tried my others with no luck.
 

racketboy

Member
Originally posted by Scared0o0Rabbit@Sep 4, 2003 @ 06:03 PM

I'd check to make sure the mod chip is firmly in it's slot, and that all teh solder points are connected properly still.
yeah it sounds like something came loose.
 

NR Pickle

New Member
When I was testing mine during the install, that's exactly how it acted when the power supply wire was loose. It wasn't loose at the power supply connection though, the wire was fraying off of the chip. Had to break it off, strip the wire and redo it.
 

Chris

New Member
Well i tried it. For a while it had problem starting again, so i resoldered, but it still has the same problem, so im guessing its a lost cause since i check everthing.
 
Top