Stuck at the SEGA black screen and flasher menu never appears

merdecas

New Member
Hi

I have a Sega Saturn Model 2 (PAL EUROPE) and I am trying to flash my Action Replay with Pseudo Saturn Kai 6.324. I can do the swap disc method since I can play some backup games using this method.

My problem is, when I boot the CD-R burned with "pskai_sdm_flasher.iso" (I also tried with pskai_alternate_flasher.iso) I can reach the SEGA LICENSE screen (after reboot) but it stays stuck here and the flasher menu never appears. After some minutes, the CD-R stops spinning.

I do this without the Action Replay inserted.

Can someone help?
Am i doing something wrong or missing some step?

Thanks,
Merdecas
 

merdecas

New Member
Hi again...

After several hours of trying ... and after asking for help on this forum ... I tried another swap method that I found on this forum. It is simpler and it works. The best thing is that with this method the flasher menu is shown.

My Action Replay is now flashed and works nicely!

Swap method used (from Saturn swap-disc hangups...):
1- Power ON your saturn with the cdr inside
2- When the cdr completely stops already on cdplayer, swap for the original.
3- Press RESET, let saturn read the security ring from the original, then swap for the copy just like double-swap's 2nd swap.
 
Top