Lunar SSS English Patch

Translating Lunar Silver Star Story 1.5.1

Dub or “subtitled” version? I dont currently have an ode to transfer saves to, so the best i can do is try and replicate in mednafen for now
Subtitled.

I managed to get through. I had an instance of freezing on two of those battles with the sphere face enemies before I uploaded a save. I didn't try AI the third time and everything seemed to be fine. Froze once at the cutscene FMV when you become a Dragon Master. It could have been my ODE or Pseudo Saturn Kai flashed Action Replay. I didn't have any problems until I got to this point and turned those off.

I also have the Twin Operator installed in my Saturn if I wanted to play through the MPEG version. But I don't think I'll try anything until a Working Designs text option happens for that one because I can't stand the Dub.

Thanks.
 
It's a shame you guys can't do Lunar 2 for the Saturn with the Working Designs script as horrible as it is.

The Saturn version of 2 starts and exits battles so much faster than the PlayStation version.

I tried looking at DATA.PAK. I have no idea how it's able to be extracted. I'm assuming that all the text resides in there.
 

Mr Conan

Established Member
It's a shame you guys can't do Lunar 2 for the Saturn with the Working Designs script as horrible as it is.

The Saturn version of 2 starts and exits battles so much faster than the PlayStation version.

I tried looking at DATA.PAK. I have no idea how it's able to be extracted. I'm assuming that all the text resides in there.

I started looking at it, just a file extraction tool for now.... MrConan1/lunar2_eb_sat_tools

The data.pak is a big archive, same format as the PSX version (although no embedded filenames). Script and text formats are completely different from Lunar SSS though. From what i've looked at they completely rewrote the game engine.
 
I'm still on 1.5, was the Nall mid-battle resurrection "freeze" fixed? I have also now noticed it is only when Luna is in your party, and I hear a tiny bit of Luna's voice before it cuts out and triggers stop firing (though idle animations and music continues).

edit: I'm on a Saturn and have no way to upload any saves, btw.
 
Last edited:

Mr Conan

Established Member
I think we found the Nall freeze was due to the music sample being too long; 1.5.1 shortened it so it should be fixed. The long term solution is to reverse engineer the audio driver better and figure out why longer samples in some cases cause issues (Which will probably allow for dub audio in sssc too). Right now I’m cleaning up some preliminary findings on Lunar 2 text encodings (I distracted myself), but will eventually get back to fixing the Lunar 1 stuff.
 
I began to play 1.5.1 english dub on real japanese hardware. I burned the game twice : first I patched my original game (version 1.05) and burned it then I downloaded a prepatched english dub iso found on internet. However, I still encounter the same bug.

When a character is revived by Nall, most of the time (it worked fine at least once though), the music continues to play and standing still characters and monsters animations play for ever... as if the resurrection script was paused. I could hear Nall talking right before the bug but could also hear the first second of Luna's healing song sample right before the "freeze" without any reason.

The only thing I can do when this bug happens is going back to title screen with ABC+Start (so it's not a crash).


lunar.jpg

The game stays like this endlessly.
 
Last edited:

Mr Conan

Established Member
That sounds like the same issue others have reported. Is it happening on an ode or with cdrs? I’ll add it to the list of bugs in the other thread.
 
Btw, where is the other thread with the list of bugs? I couldn't find it o_O

Does the jp undub version suffer from the glitch I encoutered in dub? I'll probably burn and beta test the undub then.
 

Mr Conan

Established Member
Btw, where is the other thread with the list of bugs? I couldn't find it o_O

Does the jp undub version suffer from the glitch I encoutered in dub? I'll probably burn and beta test the undub then.
The current status and bugs are in this thread, which got buried:

The jp undub version doesnt have the glitch since it is using the original sound samples. The issue has something to do with the fact that english audio samples are longer than the originals. This seems to be fine for some audio samples, but not others. Havent tracked down the culprit yet.
 
OMG I feel stupid, I reported what's literaly written in that thread xD

Thank u. I'll burn and test the sub version.
 
Last edited:

Mr Conan

Established Member
Actually, I edited the thread and added it after you reported it (i think someone else mentioned it on discord, but we couldnt replicate it), so dont feel bad.
 
It’s still freezing for me when someone is revived by Nall in combat after the audio on 1.5.1. Id like to test this more but this bug is making it hard for me to progress. Anyway we can get a patch for that and I’ll continue testing??
 
I began to play 1.5.1 english dub on real japanese hardware. I burned the game twice : first I patched my original game (version 1.05) and burned it then I downloaded a prepatched english dub iso found on internet. However, I still encounter the same bug.

When a character is revived by Nall, most of the time (it worked fine at least once though), the music continues to play and standing still characters and monsters animations play for ever... as if the resurrection script was paused. I could hear Nall talking right before the bug but could also hear the first second of Luna's healing song sample right before the "freeze" without any reason.

The only thing I can do when this bug happens is going back to title screen with ABC+Start (so it's not a crash).


View attachment 6648
The game stays like this endlessly.
Same issue I’m having did you ever figure it out
 

Mr Conan

Established Member
Same issue I’m having did you ever figure it out
Its going to require reverse engineering the sound driver. Its on the eventual todo list. The issue only shows up when certain audio clips are swapped so it seems to have something to do with the length of the clips. I can try making a patch that reverts the nall clip to jp as a quick fix if its driving too many people crazy.
 
Its going to require reverse engineering the sound driver. Its on the eventual todo list. The issue only shows up when certain audio clips are swapped so it seems to have something to do with the length of the clips. I can try making a patch that reverts the nall clip to jp as a quick fix if its driving too many people crazy.
That would be perfect honestly it’s the only issue I’ve had at all! If you could do that I’d be forever thankful and will play a bunch more for further testing :)
 
Top