VCD card shorting/blowing out mod chip?

I own several Sega Saturns. However, only one is modded. I used the wonderful chip sold here:

Scroll down to "Sega Saturn Modchip." I installed it with ease on the Model 2 32-pin IC Saturn as described here:

Now that I've gotten all of that out of the way, here is my problem. I have the Japanese Victor RG-VC3 VCD/Photo CD decoder card and have been using it for several years now on an UN-MODDED unit. Because I have an American Sega Saturn, I need to use an Action Replay/Gameshark device with it. VCDs playback beautifully and I could not be happier with it from that standpoint.

However, when I use it conjunction with a mod chip, the VCD card seems to somehow "blow out" the chip. Allow me to break it down:

  • Mod chip is installed in unit.
  • VCD card is present in unit.
  • Console is powered on and boots to the Action Replay menu.
  • Games will not boot.

When this first happened, I figured that there was some problem with having both the VCD card and mod chip in my system at once. I removed the VCD card only to find that my Saturn STILL wouldn't boot a single game or VCD/Photo CD. I tried Japanese, American and backups of both using the Action Replay and not using it. No combination worked. I then proceeded to open my unit and remove the ribbon cable going from the disc drive to the mod chip and plug it directly into the motherboard. American and Japanese games, as well as VCDs, work again.

Re-plugging-in the mod chip and removing the VCD card did not help. The mod chip became completely useless and so I ordered and installed another, which has worked without a problem. I want to try plugging the VCD card into my modded Saturn again to see what will happen, but playing VCDs on my Saturn isn't worth the risk of having to dish out another $30 on a mod chip. Keep in mind that when I plug the VCD card into my other, un-modded Saturn, it works flawlessly, just as it did after my old mod chip fried and I removed it.

So, any insight into why or how this may be occurring? Although I am a very proficient computer programmer, my knowledge of electronics and circuitry is limited. I thought perhaps the Saturn's power supply was reacting in such a way that it burned the mod chip when both it and the VCD card were present.

I don't expect much help on this, considering very few people have modded Saturns with VCD cards, I'm sure.

Thanks in advance :)


Staff member
Hey I have a VCD in a chipped saturn, works fine. Have not had a single problem with it. Not sure what could be causing the problem but the obvious solution is to watch vcds on a non chipped saturn.
Of course ;) I have a DVD/DiVX player, as well as a VCD player for Dreamcast, so I have many options. I was just wondering if there were any explanations for such behavior.
I have a Model 2 32-pin IC Saturn modded with the exact same chip and I am using the exact same VCD card (Victor RG-VC3) in it. I have never had any problems with this set-up over the last 6 months or so since I installed them. I am willing to bet that it was just a coincidence that your modchip failed you when it did. I highly doubt this, but I guess it may be possible that even though the VCD card seems to be functioning properly it is somehow damaged internally and causing your Saturn to have some sort of electrical irregularity causing your chip to blow out... Very doubtful... If I were you I would take the benefit of the doubt and just throw that VCD card right back in there :)
Got a similar setup (VC2 instead of VC3 though) and under normal circumstances, you should be fine running both the chip and card at the same time.

Looks like you've done just about everything you can already so if you decide to reseat the card and it fries your chip - yeah it'll stink to be out another $30 - but don't beat yourself up over it. I'd have done the same thing honestly.

Just to play it safe though, could you switch your currently un-modded Saturn to be my modded one and vice-versa? That at least knocks "faulty Saturn" out of the equation.