Altered Beast (Japan) on a EURO PAL Mega Drive I/I


I just got a mint Japanese copy of Altered Beast Cart, for the SEGA Mega Drive (Japanese)

I have a EURO PAL SEGA MEGA Drive I (Bulky model) console and a EURO PAL Mega Drive II (Smaller model).

All my Japanese carts work perfectly on both consoles, either by directly inserting the carts into the slot (I have trimmed them out) or by using a Universal Adaptor cart. (Nitro Adaptor 2 for PAL & NTSC MD)

But when I insert Altered Beast (JPN) cart, the typical SEGA quote comes up:

“Produced By or Under License From SEGA Enterprises LTD”

Then a Black screen and then nothing…

Same thing happens on both MegaDrives, even when I used the Universal Adaptor.

The cart is fairly mint and does not look damaged, but could it be that this specific cart has a region lock-out? Altered Beast (JPN) was one of the 1st Mega Drive games (1988) so it’s doubtful.

So does anybody have this specific Japanese Altered Beast working on his EURO PAL SEGA Mega Drive I or II?

Is this a region-lock preventing it from working, or should I assume that this is simply a defective cart?

Please any feed-back will be highly appreciated, because if anyone of you has a working Japanese Altered Beast on a Euro Mega Drive, then mine would be a defective cart, so I’ll just send it back.

Thanks in advance.
As far as I know, there are no region-specific variations of Altered Beast, although I suppose it's possible that revision 0 was only actually released in Japan...
It could be a bad cart. I know this isn't an issue on the US version of Altered Beast, but it could be a 6-button compatibility problem if you're using 6-button controllers. I had something similar happen with Forgotten Worlds, even when using the MODE button on the controller, and could only get it to work by using an actual 3-button. As I said, the US version doesn't have a problem, but maybe if it's an earlier Japan rev it could be problematic. This is unlikely, though. It could also be a PAL problem if you're running in that mode.
It could also be a PAL problem if you're running in that mode.

What do you mean?

I just have two regular EURO/PAL un-modded Mega Drives Model I & II.

No, I'm not using a 6-button pad, just a regular SEGA 3-button one. I even tried it, without a pad connected, but it still won’t go past the "Produced By or Under License from SEGA Enterprises LTD” Logo.

I have another problem with Super Street Fighter II (Japan MD). If I stick it into my EURO PAL consoles, a red screen comes up saying: “Warning! Developed for use only with NTSC Mega Drive Systems”

But when I use my Universal adaptor cart (On both MD I & II), the game does start ok, but the graphics in the levels will be really messed up. This happens in random too. One level will be ok and then the next will be messed up. I really don’t know if this is case of defective Super SFII (JPN) cart, or if my universal adaptor cart is simply just not up to the task for this game, leaving messed up graphics in the process.

Anyway, having modded my Saturn, PS-1, PS-2 & X-Box my self, I’m considering doing a 50/60HZ and country switch mod to one of my two MEGA Drives.

That should bring some light to the problem.

I found these instructions:

MD Model I

MD Model II

Are these instructions ok by the way?

I wouldn’t want to mess up my consoles?

I think I’ll try the Model I 1st, it looks very easy. Unless there is a reason I should do my Model II instead?

Any one has better diagrams/info on how to mod a 50/60HZ & country switch on MD Model I & II by the way?

The problem with SSF2 is probably caused by the adapter interfering with the mapper chip. The most obvious way to screw this up would be to omit pin B31 (the next-to-rightmost pin on the front side of the cartridge), but there are probably other things that might go wrong.
Well, I went ahead and tried the 3 known Altered Beast good Rom dumps:

Altered Beast (UE) (REV02) [!].zip

Juu-Ou-Ki (J) (REV00) [c][!].zip

Juu-Ou-Ki (J) (REV01) [!].zip

In Gens & Kega emulators set to PAL region under WinXP.

All three worked perfectly in 50HZ & did not freeze like my cart after the logo, so it might be a defective cart after all.

But I can’t be certain that my cart is in fact any of the 3 Rom dumps that I tried.

Only way to be sure is if I could dump the Rom to my computer (using the Sega CD Transfer Suite tool from here: and try it on the emu.

But I would need a SEGA CD to connect to my pc via parallel cable and I don’t have SEGA MEGA CD at the moment.

Darn! :(