Did I just brick my Staturn with a Pseudo flash?

My original, June '95 made Model 1 oval button 20 pin Saturn. Christmas present back in 1995. I cherished this thing for years, then sat it in a cabinet for display for years. A few weeks ago I decided to take it out and start playing with it again. I had to adjust the laser potentiometer to finally get games to load flawlessly everytime, it was hit and miss with a lot of disc reading activity and sometimes no disc read. Eventually I got to the point where I was gaming regularly on it for a few days. I wanted to play more of my games, but did not want to open the package and risk scratching these ever increasing in costs game discs, so I went down the path of what it would take to get it to read CD-Rs... enter Action Replay flashed Pseudo Saturn, right?

I ordered a 4M Action Replay cart, took apart the Saturn, prepped the lid switch, did the swap trick, got the flasher loaded, Lite version, flashed the cart, at least it looked like it successfully flashed the cart, then restarted the system. Tried one burned game, and I get the "couldn't initialize the cd block" message, any game, including originals. I removed the Action replay cart, things got worse. Boot process was not showing the animation, just the Saturn splash screen, then nothing. Tried restarting a few times, nothing. I then removed the battery in the rear, restarted, black screen. Pressed the reset button, nothing, black screen now, not even splash screen. Putting in the Action replay cart doesnt bring it back either. Is this Saturn toast? It would really hurt if it did, this one is kind of special to me. Please help
 
Last edited:
Rechecked all of my connectors, seems that the cd door open connector was not fully inserted... weird, an open cd door never caused it to not boot before. I reseated it and got it to boot, but I'm back to the failure to initialize the cd block, I dont even see activity going on with the cd drive period, almost as if it coincidentally died ? I get a small movement out of the laser when first powered on, then nothing. No spin, no message saying door open.
 
Crisis averted.

I gave another look over, this time when I opened it up, I check every connector, even ones I hadn't touched before. Turns out that some how, in this whole process, the board that connects the cdrom (and video card) had come completely disconnected from the motherboard. Plugged it all back in, and everything working perfectly again. That was a few years off my happiness shaved off and recovered all in the matter of an hour lol

I guess the Sega Gods just had to have to have another laugh with me, just for fun. Thanks to anyone who took the time to go through this drama with me.
 
Top