• Rise from your gwave!

SaturnOrbit for Windows

Discussion in 'Saturn Dev' started by RockinB, Jun 1, 2005.

  1. RockinB

    RockinB Staff Member

    Recently I found SaturnOrbit in the internet,

    it's an all-in-one installer that claims to have everything you need to develop stuff for SEGA Saturn.



    I've tried it out myself:

    The SaturnOrbit_r1_setup.exe got only 55.6 MB size and expands to almost 400 MB after installing.

    If you don't have so much space left, you can deselect components.



    After installing you're asked if all included code examples should be build.

    This takes about 1 hour on my old computer and produces way over 100 ISO CD images and binaries to

    test on emulator or real Saturn hardware.



    I guess that's the reason for the small size of the installer, as those files generated while compiling take up a lot of space.

    There are some similarities to DCFreeDev(with which my GBAX GP32 entry was made),

    because it includes Dev-Cpp IDE.



    You can compile an example by using Dev-Cpp IDE or clicking on a batch file.



    Everything worked for me right from the start, you should try it out and enter Saturn dev now! :thumbs-up:
     
  2. Omni

    Omni New Member

    Rockin-B, did you find this on the internet, or create it yourself? I thought SaturnOrbit was a package you were creating.

    Though I downloaded it. Haven't had time to test it yet, but, all of these resources are really sweet...
     
  3. RockinB

    RockinB Staff Member

    The package doesn't contain any info about the author.

    Maybe there is a reason for that.

    But hey, one advantage is that nobody can be blamed if somethings wrong. :lol:
     
  4. racketboy

    racketboy Member

    Very cool!

    I've been waiting to get an actual link to this.

    (BTW, Rockin'B, I'll get you a response to your PM soon :) )
     
  5. vbt

    vbt Staff Member

    stats of downloads :

    july (till 22) : 130 hits for 2 402 764 ko

    june : 463 hits for 7 828 288 ko

    :)
     
  6. RockinB

    RockinB Staff Member

    Wow, that's more than I expected :thumbs-up: . Wanted to ask you if you got stats, anyway.

    I did a good job in publicity, eh?!

    Some feedback from me:

    FAQs in my help forum

    Missing stuff / bugs:

    - BGCON needs dos4gw.exe

    - RB library not as elf version

    - sega_cmp.a not correct initially, why (recompile may helps)?

    - in .dev files: make absolute paths instead of relative

    todo for next release:

    - new compilers GCC 4.0 (some examples which not use any library must be fixed - update paths)

    - add DOSBox <- great tool which allows to use SN tools and GAS and everything which doesn't work on WinXP

    - c++ support in makefiles

    - better support for custom compile flags in makefiles

    - add tools like: mp32wav, wav2mp3

    - include SaturnGameTutorial & Demo

    - include Reinharts star game

    - make something like firststeps.html which guides through first time users

    Your feedback?

    BTW: anyone can make a new release, afaik everything needed is included
     
  7. vbt

    vbt Staff Member

    let's hope people who have downloaded SaturnOrbit will participate to the contest.

    No idea, I recompiled it with no specific change and it works.

    I want to change the install path :) my c: is too small (0.97go). I had to remove some files of win98 to install only a part of SaturnOrbit.

    How to create a new version ?

    NB : I will add again some tools on the SX saturn page :) .
     
  8. Borisz

    Borisz Ban Hammered

    just link to LAME instead ;)
     
  9. RockinB

    RockinB Staff Member

    Just start with a clean new installation of the WHOLE SaturnOrbit (COFF + ELF + .PIF files for Win98),

    then apply patches and changes,

    then create a new installer using the supplied file.

    I think it uses Inno Setup compiler, but I'm not sure, so refer to the docs in SaturnOrbit.

    Maybe a custom install path should be something to think about, then we would need an environment variable holding the SaturnOrbit location.
     
  10. RockinB

    RockinB Staff Member

    Importand:

    Before compiling the setup.exe file, do a whole clean using the batch files. Or else you might wonder about the filesize :D .
     
  11. Pinchy

    Pinchy New Member

    I liked the saturnorbit except for one thing, not having control over the install directory. I had to grep and replace all the occurances of that lousy c:\saturnorbit\ path. (doesnt work on .lnk's but thats ok)

    Some of the directories in the top level could use some moving and cleaning up.

    Other than that its really the easiest way to get started with deving for the saturn.
     
  12. RockinB

    RockinB Staff Member

    EDIT: this one is bullshit, as some SGL function is executed first in section SLSTART and that function calls main(). It's name is possible slStartSGL or SGLStart.

    The link scripts need to be updated to make C++ programs work with the newest KPIT GNUSH v0601.

    Sections like .sh_frame and .gcc_except_table are needed.

    In sections data, text and rodata:

    *(.data.*)

    *(.gnu.readonce.d*)

    *(.text.*)

    *(.gnu.readonce.t*)

    *(.rodata.*)

    *(.gnu.readonce.r*)
     
  13. Omni

    Omni New Member

    Dumb question:

    I recently redownloaded SaturnOrbit (I previously did a massive clean on my hard drive and took off nearly everything) but whenever I try to install it, it gives me an error.

    "The application failed to initialize properly (0xc0000005). Click OK to terminate the application."

    It gives that error twice and then closes. Has something happened to the package? I've redownloaded it something like four times now.
     
  14. RockinB

    RockinB Staff Member

    The package itself should be okay, since it has been successfully downloaded before. Maybe your download was interrupted before completion. The file size is exactly 58.361.410 Bytes, please compare with yours.

    Try using a download manager which supports pause and continue of downloads, like FlashGet. Always recommended for big stuff. If it still doesn't work for you, someone else should try downloading to see if it's really corrupted. I'm on dialup...
     
  15. Omni

    Omni New Member

    Windows says my fifth download of the Saturnorbit EXE is

    55.6 MB (58,363,904 bytes)

    Gives me a new error message now:

    "Only part of a ReadProcessMemory or WriteProcessMemory request was completed."

    Trying again...

    EDIT: Sixth time! It works! WHOOHOO!
     
  16. Dalklehel

    Dalklehel New Member

    I get this error when i load the saturn compiler...Im kind of new to this.

    there doesnt seem to be GNU Make file in PAH or in Dev-C++'s Bin path.

    Please make sure that you have GNU

    Make and adjust Bin setting or system PATH enviroment

    variable and that make setting in Compiler Option contains correct filename, otherwise

    you will not be able to compile anything.

    How do i fix this in the compiler settings?

    Dalklehel
     
  17. RockinB

    RockinB Staff Member

    Have you set the C:\SaturnOrbit\devcpp.ini file in the Environment Settings of C:\SaturnOrbit\devcpp.exe? If not, try that.
     
  18. RockinB

    RockinB Staff Member

    Now that I've experienced the same issue when installing SaturnOrbit on a fresh computer, I can tell a simple solution:

    Workaround 1:

    Open file C:\SaturnOrbit\devcpp.ini in a text editor. At the bottom of the file is a list called Compile Sets. It assigns index numbers to Compile set names defined in the file. (The first 4 indices are placeholders for compilers that are obviously not installed on your system.) So replace "Default Compiler", "dummy_GP32" and "dummy_Dreamcast" with "sh_coff".

    Workaround 2:

    Download and install Devcpp in addition to SaturnOrbit:

    http://prdownloads.sourceforge.net/dev-cpp/devcpp-4.9.9.2_setup.exe
     
  19. Omni

    Omni New Member

    SaturnOrbit's KPIT compilers don't work in Vista...

    When running BUILDELF or BUILDCOF, I receive the

    cc1: invalid option '2'

    For the "-m2" option. I described this earlier under my problems doing a manual standalone install of KPIT under Windows Vista.

    Does anyone have any insight into why the SH2-GCC compilers do not work under Windows Vista?
     
  20. Omni

    Omni New Member

    I was very happy to see that dropping in the compiler made using Antime's instructions for creating a cross-compiler remedied my problems.
     

Share This Page