• Rise from your gwave!

SaturnOrbit for Windows

Discussion in 'Saturn Dev' started by RockinB, Jun 1, 2005.

  1. antorino

    antorino New Member

    Sorry for pulling this old thread out of the mud.

    As a fan of Sega Saturn I thought about trying some programming on that console.

    I am not very new to software development since i did a traineeship in that subject. However this was mainly object oriented programming with Java, VB.net, Powerbuilder, Delphi and I made only desktop applications.

    So I am not really familiar with C and configuring compiler stuff.

    I downloaded SaturnOrbit and tried to setup the IDE. First I got an error that no compiler was found.

    Then I added C:\SaturnOrbit\devcpp.ini file in the Environment Settings and now I get an error and crashdown when starting. I can post the exact error message later.

    Maybe I should install Devcpp although I don't know what it is?

    Sorry if this seems very noobish to you but unfortunately the guide and sample project provides not much help for someone who is new to C. Also I could not find docs for the most common libraries and how to use them.
     
  2. antorino

    antorino New Member

    This was the error message:

    "Exception ERegistryException in module devcpp.exe at 0007ABCA. Failes to set data for ".

    Adress: 0X00552F93

    Error Message: Access violation at address 00552F93 in module 'devcpp.exe'. Read of address 00000010"

    I would be happy if someone could help me. I really want to get a deeper look into it.

    edit:

    okay, I installed dev-cpp and had no error after starting. I could also use the ini-config of saturn orbit.

    then i compiled the SaturnGameTutorial and got some files as a result.

    Is the file "sl_coff.iso" a finished iso that i can mount right away and try to start in emulator? guess i have to find out. Sad that there is not much of tutorials out there...Seems like I have to go through that by myself [​IMG]

    edit2:

    I started the demo of rockin-b in emulator and everything worked fine [​IMG]

    This is pretty cool. Now I am ready to program, compile and test. Tomorrow I will start looking at some examples and try to understand the code of rockin-b's demo!
     
  3. CD-r

    CD-r New Member

    i am new and i cant create iso with mkisofs

    i create a folder (nod) with mkisofs , main cpp, project 1 dev , cygwinn1.dll, make fil and a subfolder "cd" with ip.bin , ABS, BIB, and CPY

    i try this in the command (like the tuto)

    C:\>SaturnOrbit\nod\mkisofs -quiet -sysid "SEGA SATURN" -volid "SaturnApp" -vols

    et "SaturnApp" -publisher "SEGA ENTERPRISES, LTD." -preparer "SEGA ENTERPRISES,

    LTD." -appid "SaturnApp" - abstract "ABS.TXT" -copyright "CPY.TXT" -biblio "BIB.

    TXT" -generic-boot IP.BIN -full-iso9660-filenames -o sl.iso cd

    SaturnOrbit/nod/mkisofs: No such file or directory. Invalid node - -

    or this:

    C:\>SaturnOrbit\nod\mkisofs -b ip.bin -o sl.iso cd

    i need explanations , do i write something in ABS , BIB, and CPY text ?

    what name enter in the command line , project 1 ? like this =>> mkisofs -b project1 -o sl.iso cd

    i need help
     
  4. antime

    antime Extra Hard Mid Boss

    mkisoft won't search subdirectories for files, so in your setup the boot image's filename is "cd/IP.BIN" etc. Note that the appid/abstract/sysid etc. aren't actually needed. You do need at least one file in the root of the filesystem even if you don't use a first read file though.
     
  5. CD-r

    CD-r New Member

    so, what i type in the command line ?

    mkisofs -b cd/IP.BIN -o sl.iso cd ???

    its good?

    (at -b,

    its ip.bin i muste write or name "Project1" or other name ?)
     
  6. ExCyber

    ExCyber Staff Member

    IIRC, you do need abstract, bibliography, and copyright files for the disc to be bootable without an AR. It's been a while since I messed with this, though.
     
  7. surixurient

    surixurient New Member

    What an excellent idea! Thanks to whomever put it together.
     
  8. surixurient

    surixurient New Member

    Has anyone used SBL_601 samples built from this on yabause? They wont run for me, only the SGL ones.
     

Share This Page