Mod Problem

Ok, I finally got my saturn and some spare time to mod it but it doesn't work :-(

First off this is a PAL system. I changed the jumpers to JPN. 32 pin IC and 21 pin ribbon cable.

I then installed the mod chip using mal's A-B method and putting a wire to the 5V point. and tried to boot a JPN CDR. This gave me a unrecognisable disc message at first, but now just goes to the audio player.

I've tried:

Linking 014/016 jumpers

Turning the mod board around

Checking bent pins on the mod chip itself.

Resoldering points.

Nothing has worked and I just get the same results. I tried some PAL originals and they should give me an unrecognisable disc error - but they do the same, and go to the audio screen.

I tried the system without the mod chip and the PAL original games give me the unrecognisable disc error like they should.

Anything else I could try?
 

Curtis

Established Member
Well, for a start, don't link the 0014/0019 points - I don't know what that does, but it can't be good.

Another thing to try is soldering directly to the 14th pin on the 32pin IC. This is the "correct" method as shown by other mod install sites. It may not make a difference, but it is worth a shot.

The only other variable is the JPN switch - are you sure this works correctly? Remeber, you will get the message "game disc unrecognised" (the important bit is the "game" part) if the saturn recognises the disc but it is for the wrong region. If you only get "disc unrecognised" that means the Saturn doesn't even realise it's a Saturn game - indicating a bad burn or a damaged disc.
 
Thanks for your reply Curtis.

Linking 0014/0019 points, I meant linking each one in turn, not all three:

X-X-0 (0014) and

0-X-X (0019)

I'll give the proper mod method a go later today.

I'm pretty sure my region mod is 100%, as the Saturn powers up with the Japanese language as the default selection.

I'll look out for that game disc message as well.

Thanks again.
 
Sorted it - I soldered the signal wire to pin 14 and all is well :)

Strange that the A-B method didn't work, I thought it was 100% from reading the sticky thread. Perhaps newer mods are not working with it? I brought mine from Gamegizmo.
 

mal

Established Member
That's a bit disappointing.
sad.gif


When I've got a bit more cash I'll buy a couple more mods for some up to date testing.
 
Top