Please help! Problems with Megadrive + Mega CD

HeyFreak

New Member
I've just bought me a Mega CD 1 on ebay, it arrived today but the damn thing doesn't work.

When I turn on the power I get the Mega CD bios screen (earth and the sega logo flying about) but I can't load the games. When I put in an audio-cd it doesn't read the tracks either. When a game does start it freezes within a minute.

Is this something I can fix myself? If so, how?

And another thing. My old Megadrive 1 has this nasty buzzing sound. I can hear it from the tv (RF) and with my headphone (directly connected to the Megadrive headphone jack). Anyone some ideas on how this can be fixed?

Finally, a maybe rather silly question...

What's the lock on the left-side of the Mega CD for? I'ts for locking something I guess, but what?

Please reply...
 

racketboy

Member
First: Welcome to SX!

Second: Have you contacted the seller? It shouldn't be your resposibility to fix the thing. But if someone does know of an easy way to fix it -- go for it.

Best of luck
 

HeyFreak

New Member
Originally posted by racketboy@Sep 11, 2003 @ 04:32 PM

First: Welcome to SX!

Second: Have you contacted the seller? It shouldn't be your resposibility to fix the thing. But if someone does know of an easy way to fix it -- go for it.

Best of luck
yeah, I contacted the seller. But if it's a small thing I can fix myself I'd rather do that.

Do you know what the lock-slide on the left of the mega cd is used for btw?
 

racketboy

Member
could you take a picture of it? or find one?

I used to own a model 1, but can't quite remember what you're talking about
 

HeyFreak

New Member
hehe, i tried to find one but all the pics are taken vrom another angle so you can't see it, and I dont have a camera either...

but I guess it's not that important. Most important to me is to get rid of that loud humming noise from the megadrive and the inability to play cd's on my Mega cd...
 

dman97

New Member
The loud buzzing could mean that youre using the wrong AC adaptor. Lower wattage adaptors can cause distortion, at least thats what used to happen on my old NES.

Oh and the lock slide to the left is used for the Karaoke add on module, released only in Japan.
 

HeyFreak

New Member
Originally posted by Burning Angel@Sep 13, 2003 @ 05:33 PM

Well at least YOUR Sega CD1 turns on. Mine doesn't even power up :(
You have my sympathy :(

My Mega CD 2 is dead too. I baught it new but somehow something went wrong inside and now I have a very large paperweight...
 
Top