Sakura Wars ENG Patch not booting on PAL model 2 with modchip and 60hz switch

I own a PAL Sega Saturn model 2 that comes with a modchip and a 50/60 hz switch. I tried Castlevania: Symphony of the Night with english patch, Shining Force III Scenario 1 with english patch and other games from varying regions (SF Alpha 2 from europe, resident evil USA, Saturn Bomberman USA etc.) and they all work (so I doubt its the laser or anything). All I had to do is use Saturn Region Patcher first and change the area code to Europe.

I want to play Sakura Wars with the English Patch, but I've tried to get it to work multiple times now and it just won't boot. I keep getting the Sega boot screen, then it throws me to the CD audio player where I can start the application again, only for the same thing to happen. I've tried five different discs and none of them work.

Things I tried:

  • Burning CD-R with Imgburn (Mode1/2048) of a pre-patched image from a collection WITHOUT region patch (Application error, obviously, but still worth a try)
  • Burning CD-R with Imgburn (Mode1/2048) of a pre-patched image from a collection WITH area code patched to Europe (boot screen, cd audio player)
  • Burning CD-R with Imgburn (Mode1/2352) of an image I patched the ENG patch on myself (Japan image from a different collection) as well as changing the area code to Europe (boot screen, cd audio player)
  • Burning CD-R with DiscJuggler (Mode1/2352) hoping it was just imgburn being bad or something (boot screen, cd audio player)
  • Just....... burning the japanese image with region area changed to Europe. NO english patch. (boot screen, cd audio player)

How come other Japanese games/Japanese-english patched games work, but this one does not? I've read of hardware differences between the models and that the game can have some glitched text on Model2, but surely it boots at least?

I got a Pseudo Saturn cartridge coming in early January... will that fix the issue? I was under the assumption that I didn't really need it because of the modchip, but I need the extra save memory space anyway and it would skip the whole region patch thing perhaps, so maybe it can finally boot the game. Compatibility list shows that the game will work. Anyone got a PAL model around and can confirm to me that it does?


  • IMG_20221223_035504.jpg
    1 MB · Views: 119
  • IMG_20221223_035459.jpg
    2 MB · Views: 103
Problem is solved. I made a reddit thread here, in case you come from Google and somehow have the same strange setup as I do