Saturn Satelite?

Berty

New Member
Hi,

I have a Saturn Satelite and i cant get it to work with my Jap Model 2 Saturn that has a mod, however it does work with my PAL model 1 saturn. Could this be because of my mod chip in the model 2 jap saturn?
 

Berty

New Member
Tried that,

all other carts work, when i put in the game and the cart, the sega logo comes up, then the satelite screen, then it either goes to the sega logo again and crashes or goes to the cd player menu. I have tried with both originals and non originals from all regions.
 

mal

Member
I'd really be surprised if it was because of the mod, but you could always try booting with the cart but without the mod to find out for sure.
 

Berty

New Member
Hey mal,

I was more concerned about it being a bios revision issue. The boot sequence is strange, as on the Jap mod system, it goes to the sega logo, then the satellite screen and then it either goes to CD player or Sega logo and hangs.

On the PAL system, it goes straight to the satelite screen, then the sega logo, then its fine.

On the jap saturn i think that the mod is causing it to go to the sega logo first and then stuffing up the rest of the process.

Whcih brings me to another point, what information does a mod chip return? I know it authenticates the CD's but does it just send a generic code back?
 

Curtis

Member
I don't think the chip actually authenticates the CD, rather it just tells the controller that the CD has been verified. There is actually a difference between the two...I think
 
Top