Sega CD BIG help needed

ConsoleManiac

New Member
Hi all,

this is my first post here, and I dunno why I didn't hink about you guys: I searched all over the net to solve this. I hope you can help...

I have two SegaCDs (one is a NTSC model 2, the other is a PAL model 1) which, suddently, doesn't load any CD. They have the "ACCESS" light blinking, and when you put the CD in it starts looking for the CD (the model two I can hear doing something, not for the model 1) and then the message on screen says "NO CD".

Do you know what can I do to solve this big problem? I have too many games I like to play on these machines, I can't leave them this way.

Thanx again

P.S. I have a Jap saturn (model HST-0001, the first grey one) which at sudden started doing the SAME thing ???
 

ConsoleManiac

New Member
Hi,

I tried cleaning the lens inside for both the Sega CD model 2 and the Mega CD model 1, but no luck: they still don't load the damn CD.

Any clue?

Thanx
 

ratfish

Member
I'm having the same problem with my CD model 2, and I have not gotten it to work either after openining it, cleaning dust out, cleaning the power cable connectors, cleaning the lens, blah blah blah.

Sorry I can't be of any help, but you have my sympathy.

I'm coming close to just giving up on it and going out to find another one.
 

ratfish

Member
I do have 2 separate segacd model 2s that both don't work.

I don't know if it's a problem with the laser.

I was starting to think that something was wrong with the contacts on the genesis. I've cleaned those too, but they look pretty messed up.

I was going to try to find another genesis with better/unused contacts and try that in the cd unit.
 

ConsoleManiac

New Member
I don't think it's related with the Megadrive you attach to the MegaCD because I tested two MCD with the same MD, and one of them works flawless.

Moreover, same exact same thing happens with a Saturn a friend of mine has.

I'm going to hate that damn "ACCESS" led!

Plz, som1 who solved it!!! :
:

ConsoleManiac
 
Top