Sega Saturn Mod Chip Model 1 Help!

Zer0-2k10

New Member
Hey, Sega Xtreme Community.

I have Recently Just did a 21 pin to 20 pin conversion for my model 1 on a Racketboy modchip.

I'm getting a few problems i did everything correctly. Ive used the new horizontal method to install the modchip on the model 1 Sega Saturn with a ribbon cable.

Ive checked for bridging with my Multimeter and im still getting these errors.

At First i got:

No Cd Rotation

No Boot up Animation

1 Yellow Sphere on the left and a Red Sphere on the right

Then I tried Reinstalling the +5v Cable on the 2 pin from the top on the power supply and got this:

No Cd Rotation

No Boot up Animation

Green Sphere on the left and yellow sphere on the right

then i tried flipping around the ribbon cable that goes inside the modchip and i got this as well:

No Cd Rotation

No Boot up animation

2 green cubes

Now Ive looked up on Sega Style's Modchip Installation Troubleshooting page and i was told to fix the signal bridging or the no power going to the mod chip problem for the 2 green cubes.

Ive Redone the wire jumping for the signal wire and resolderd the +5V cord to its place and i put it back together and i got the red sphere on the left and the Yellow sphere on the right again.

Please Help.

Thank You

Zer0-2k10
 

usafcamarodude

New Member
Did you find anything out? I recently did the same mod, soldered everything carefully, double checked everything with a multimeter and I am having the exact same issue.
 
Top