Grandia English Patch

Translating Grandia 0.9.2-RC

dibz

Boss
Staff member
It happened to me as soon as I started a new game during the intro, the music was cutting out. Then when I got control in the first town I just let the music play and it kept cutting out and starting over.
Gave it a go this morning w/ the latest patch on my fenrir. Watched the opening video, started a new game, watched that video, and played for around 20 minutes. Didn't have any sound issues I'm happy to report.
 
Gave it a go this morning w/ the latest patch on my fenrir. Watched the opening video, started a new game, watched that video, and played for around 20 minutes. Didn't have any sound issues I'm happy to report.
I just tried creating a new file and made sure the post MD5 E1C485B2952ECA6DCCBE876DEE048357 matched the ISO. Converted it to ccd because Fenrir can't read a wav file (the useless track 2 audio warning) and still get skipping. As stated before no issues on my NTSC Japanese model 2 with a Phoebe and NTSC Model 1 with Rhea. For what it's worth my Fenrir is in a NTSC model 1. I recorded the sound skipping with my phone. I tried running a clean non patched version and the sound still skipped. No idea why my Fenrir doesn't like this game just like themadhaxor's Fenrir. Running the latest 2020/10/28 Fenrir firmware. So I don't think it's a patched ISO issue.
 

Attachments

  • Grandia_Fenrir_Sound.mp3
    977.7 KB · Views: 0
Last edited:

dibz

Boss
Staff member
I just tried creating a new file and made sure the post MD5 E1C485B2952ECA6DCCBE876DEE048357 matched the ISO. Converted it to ccd because Fenrir can't read a wav file (the useless track 2 audio warning) and still get skipping. As stated before no issues on my NTSC Japanese model 2 with a Phoebe and NTSC Model 1 with Rhea. For what it's worth my Fenrir is in a NTSC model 1. I recorded the sound skipping with my phone. I tried running a clean non patched version and the sound still skipped. No idea why my Fenrir doesn't like this game just like themadhaxor's Fenrir. Running the latest 2020/10/28 Fenrir firmware. So I don't think it's a patched ISO issue.

The game could be more sensitive to problems then others perhaps? It could be the conversion too, which I also had to do. I'm not sure we should clog this thread up w/ Fenrir troubleshooting. Maybe throw me a DM on Discord? Mine works fine, so theoretically it should be solvable.
 

TrekkiesUnite118

Established Member
Those are all the same. Grandia doesn't have any different revisions. As long as the data track you extract with ISOBuster matches the checksum it should be good. You should even be able to use your own copy.
 
My physical discs are too scratched unfortunately. I obtained "backup" copies of Disc1 and Disc2 in CHD format. Converted them to BIN/CUE using CHDMAN, then tried using ISOBUSTER to convert Disc1 into an ISO following your readme and got an error. When I checked the Track01 contents it looks like there's an issue with "CDDA1" (red "X" next to it). This is all a bit high-level for me to wrap my head around so I think I'll call it a night and try again tomorrow (unless you have any tips on how to convert CHD straight to ISO, or would be willing to PM me your copy?)
 

TrekkiesUnite118

Established Member
I have no idea what converting from CHD to BIN/CUE would do. And I will not send you a copy as that's piracy.

Honestly just look for a BIN/CUE rip from redump if you must use a pirated copy. They're not hard to find if you just google it. Even your scrached copies will still probably rip fine using your PC as long as there's no top layer damage.

Just follow this guide exactly:
 
whitezombie said:
Yeah I think it's an issue with Fenrir because I have the same issue with Grandia using Fenrir. The music skips alot and starts over for me. I convert all my images to clone cd format via this method. I use CD Manipulator version 2.70 fix-7.


The Iso Zone Forums • View topic - Sega Saturn RHEA/PHOEBE-Diskjuggler CDI Replacement!

I have a Phobe and a Rhea and the music does not skip when I use the conversion method above.
Shame I don't use OR like Daemon Tools...it's just too finickey and has never worked correctly for me...

Thanks for the info though :)

...never figured the audio tracks for Grandia was a Fenrir issue...but it's the only game it does it for [even SF Zero 3 has no issues]
 
I'm happy to report that Fenrir dropped a new firmware update, 2021/02/02 333126c7. In the release notes it states CD timing rewrite. I updated and Grandia's music no longer skips and cuts out on my Fenrir. I tested a clean unpatched Bin+Cue and my 0.9.1-RC patched ccd image for 30 minutes each.
 
Last edited:
Hi there

Does anyone have a save file for this game that start in disc 2?

Or just throw at me all the saves you have...

I've been playing the game on my Saturn model 2 with MODE and my stupid Memory cartridge decided to die off on me...wish I saved to the internal memory instead of losing 80 hours of game play :(

Also thank you so much for even bothering to translate Grandia for the Saturn!
 

TrekkiesUnite118

Established Member
TrekkiesUnite118 updated Grandia English Patch with a new update entry:

Version 0.9.2 Final Release Candidate

This update has converted the patch over to using Knight of Dragon's Sega Saturn Patcher utility. This should make patching a lot easier now. Instructions for how to apply the patch are included in the README file.

  • Changes in this version include the following:
  • Fixed scripting errors on the Steamer Ship.
  • Fixed various minor pointer issues in menus.
  • Fixed minor alignment issues in some menus.
  • Repurposed Save File Comment to now be the first 10 characters of where you...

Read the rest of this update entry...
 
Trying to patch the new version and am having errors.
No matter what I try I get:
Failed to send Cue Sheet! Reason: Invalid Field in CDB

I tried patching the image I have. Then I used the patcher to make a new image to patch. Neither worked. Both had the same error.
 
What image were you trying to patch?
I'm not sure what version it is, but it's the same ISO and Wav file I used for all of the other patches... How can I find out what version it is?
In the past I would use xdelta to patch and then copy the wav file to the patched image's directory. I tried to just patch it. I tried to copy the wav over too... neither worked still had the same error. I had a similar error when trying to patch SOTN. I have not had luck with this patcher today or in the past.
 
Top