Server maintenance

dibz

Boss
Staff member
There were updates to the server earlier today, please let me know if you run into any problems. Quite a bit changed, if you're unable to access the forum for whatever reason please tag me in the SegaXtreme discord. I may be slow to reply, but that's absolutely normal...
 

Attachments

  • maint1.png
    maint1.png
    63.5 KB · Views: 4,566

slinga

Established Member
Hi Dibz,

The forums seem to be rendering really poorly. I tried on both Firefox and Chromium desktop browsers. I'm attaching a screenshot.

Also while you are at it, can I request that some of the stickied Saturn Dev threads be be unstickied? They take up a lot of space on mobile. In my opinion keep:

1) Pseudo Saturn Kai official thread
2) Collect Saturn Github Projects
3) SEGA Saturn 25th Anniversary Game Competition (for a few more months)
4) SegaXtreme discord

and unsticky the rest. Thanks.
 

Attachments

  • forums.png
    forums.png
    103.4 KB · Views: 41
Last edited:

dibz

Boss
Staff member
Hi Dibs,

The forums seem to be rendering really poorly. I tried on both Firefox and Chromium desktop browsers. I'm attaching a screenshot.

Also while your are at it can I request that some of the stickied Saturn Dev threads be be unstickied? They take up a lot of space on mobile. In my opinion keep:

1) Pseudo Saturn Kai official thread
2) Collect Saturn Github Projects
3) SEGA Saturn 25th Anniversary Game Competition (for a few more months)
4) SegaXtreme discord

and unsticky the rest. Thanks.

Agreed on the stickies, I'm not a fan of how difficult it is to tell the difference between them and normal threads either. I'll get to that in a bit. Oddly enough the display issue didn't happen to me until I visited the saturn dev forum a second time, the first time it displayed normally; it does seem to be related to the theme though. I've set the default for the forums back to the xenforo default which fixed it for me, but you may need to change yours manually.
 

dibz

Boss
Staff member
Hi, please how can I get away from this light theme hell and be back to the dark one?

Ultimately I need to either fix the style myself, or download a free/purchase an updated style; I switched it to the non-colored version of the dark theme and that doesn't seem to have the problem with sub-forums that the colorized one does but I'm not sure since the problem wasn't consistent for me before. I left them selectable by users for now.
 

slinga

Established Member
The forums seem to be back to rendering poorly at times. I dunno what triggers it. On Desktop it seems good, on Android it seems to still have the issue from the screenshot above.

Also any luck getting URLs to look different from regular text? Thanks in advance.
 

dibz

Boss
Staff member
The forums seem to be back to rendering poorly at times. I dunno what triggers it. On Desktop it seems good, on Android it seems to still have the issue from the screenshot above.

Also any luck getting URLs to look different from regular text? Thanks in advance.
For a while I thought it was theme related, but it doesn't seem to be the case. Switch to the "SegaXtreme Dark" theme (link is on the bottom left) and that has better colors, I'll change the default later on. I have a new paid theme that's still waiting for me to set it up too; I don't think it solves the root of whatever the issue is though. I'm pretty sure it's a configuration issue with one of the supporting services and not the forum itself; I just haven't had enough time to dig into it enough.

Somewhat related, I need to look into optimizing the mobile version of the site as well -- it's performance is terrible for loading time compared to the desktop site.
 
Top