Sega Saturn Patcher

Sega Saturn Patcher Discussion Thread 1.91 BETA

Knight0fDragon

Patron Supporter
Knight0fDragon updated Sega Saturn Patcher with a new update entry:

Update to 1.91 BETA

Sega Saturn Patcher V1.91 (Beta for 2.0)

(C) 2021 Knight0fDragon - Knight0fDragon@gmail.com

If you would like to say thanks and offer a donation, I accept only PayPal
at knight0fdragon@gmail.com

Thanks to everybody over at SegaXtreme and Sega Saturn Shiro, along
with various people communicating with me on the side,
working out all of the kinks with this program.

Special thanks to dibz' and the rest of SegaXtreme.met for providing a home for resources and...

Read the rest of this update entry...
 
It seems that Version 1.3 of the patcher actually works much better than the recent one. It Definetly is the better one, at least for Dracula X.
 

Knight0fDragon

Patron Supporter
Yes, sorry. 1.91 BETA is well, a beta haha.

I think I said somewhere that you should try other versions since, the permissions were giving me issues across different versions of 10.
 

Knight0fDragon

Patron Supporter
I need to get it out publicly. Wasn't expecting all of this to roll out this fast. For now, you can change SSP to ZIP, go into the file, and change the version.txt number inside of it. I will get a 1.91 version up later on tonight.
 
Hello!
I'm facing trouble to make it work on Windows 7 x64...

The patcher runs fine, recognize the game format (*.BIN) and recognize the patches too (tests with Grandia and Death Mask).

When the program start the patching process, it freezes in a couple seconds and return the message "SegaSaturnPatcher.exe stops working".

Any ideas what is wrong? Or it don't work under Windows 7?

I've tried to clea the temp folders and reinstall .Net SDK 5, without success...

EDIT: I made the *.BIN images with IMGBurn and my original discs twice... tried CCD format too....
Thanks!
 

Attachments

  • screen2.PNG
    screen2.PNG
    97.5 KB · Views: 65
  • screen1.png
    screen1.png
    76.2 KB · Views: 72
Last edited:

Knight0fDragon

Patron Supporter
I would check if your windows temporary folder is clean and you have space. Also, I strongly recommend not to use the CD option in that build, and instead use the CD Image option if you have it.
 
I would check if your windows temporary folder is clean and you have space. Also, I strongly recommend not to use the CD option in that build, and instead use the CD Image option if you have it.
Yeah, I did it again (clean the temp and prefetch folders)... tried to update the Windows, restarted my machine... tried it in another desktop, no game for me...
 
I am also trying to patch Gradia 0.96 Disc 2 on Windows 11. I load the same image I always use it loads. I load the patch. I ask it to create an image and it spins and closes. I have used the patcher many times including for Bulk Slash, but it's not working for Grandia 0.96.
Tried with admin privileges and even in compatibility mode for almost everything. It does not work for Grandia 0.96.

I did notice that nothing shows up in the "Meta" and "ReadMe" sections of the patcher when loading Grandia 0.96.

The image attached shows what happens when I load Grandia image and then the patch with the blank Meta and Read Me sections.

grandia.png
 
I've also been having some difficulties using the patcher. I'm attempting to create a patch for Wipeout XL that replaces the music and some of the in-game text.

I'm able to create an ssp file with the most recent version, but the patcher crashes while applying it. Some older versions will patch successfully, but the resulting disc images always fail to load on both emu and hw (they'll go past the sega logo and get stuck on a black screen). I've tried quite a few things to work around it (different disc images, versions of the patcher, different machines, etc.) but haven't had any luck so far.

I've used the patcher before for Grandia/Dracula X/Bulk Slash and didn't run into any issues, so I'm wondering if I'm doing something wrong with the patch creation or maybe it just doesn't play nice with this particular game.

EDIT: I should probably also clarify that the game does work correctly with the modified files when they're applied manually.
 
Last edited:
I don't know if the issue is in the patch, or the patcher, but when I apply the 1.51 dub patch to my lunar image, the resulting cue file throws a invalid field in parameter error in imgburn, it appears as though the patch isn't providing the correct track indexing but I just don't know if it's the patch build, or the patcher itself causing the problem. It's not the write speed warning either, as that shows up on every image I've ever burned, it's the cue sheet that seems to be the problem. Any ideas on things to try?



I 07:48:48 Operation Started!
I 07:48:48 Source File: C:\Users\Eric\Desktop\Atlantis\Lunar\LUNAR SILVER STAR STORY.cue
I 07:48:48 Source File Sectors: 301,131 (MODE1/2352)
I 07:48:49 Source File Size: 708,260,112 bytes
I 07:48:49 Source File Volume Identifier: LUNAR_SILVER_STAR_STORY
I 07:48:49 Source File Volume Set Identifier: LUNAR_SILVER_STAR_STORY
I 07:48:49 Source File File System(s): ISO9660
I 07:48:49 Destination Device: [2:0:0] HL-DT-ST BD-RE BH10LS30 1.02 (H:) (SATA)
I 07:48:49 Destination Media Type: CD-R (Disc ID: 97m26s66f, CMC Magnetics Corp.)
I 07:48:49 Destination Media Supported Write Speeds: 24x, 32x, 40x
I 07:48:49 Destination Media Sectors: 359,844
I 07:48:49 Write Mode: CD
I 07:48:49 Write Type: SAO
I 07:48:49 Write Speed: 2x
I 07:48:49 Lock Volume: Yes
I 07:48:49 Test Mode: No
I 07:48:49 OPC: No
I 07:48:49 BURN-Proof: Enabled
W 07:48:49 Write Speed Miscompare! - Wanted: 353 KB/s (2x), Got: 2,822 KB/s (16x)
W 07:48:49 The drive only supports writing these discs at 24x, 32x, 40x.
E 07:48:50 Failed to send Cue Sheet!
E 07:48:50 Reason: Invalid Field in Parameter List
E 07:48:53 Operation Failed! - Duration: 00:00:04
 
I am trying to patch a copy of Gun Griffon II using the app. I cannot seem to apply this patch to my image. Using the Sega Saturn Image Patcher I get an error stating the patch requires version 1.95.8035.20705 or greater.

I am new to this so I am not sure if it is my image, the patch, or the program. Any help is appreciated. Thanks.
 
Hi there, I'm trying to patch the Shining force 3 difficulty mod from shining force central into my scenario 1 translated game and I'm running into the issue where the patcher runs but then conitnues to use up more and more memory until it has taken everything my system has. I've left it running for 10 minutes or so but it never completes.

I've had a quick look through and I can't see anyone else who seems to have this issue, am I doing something wrong?

I've tried 1.9 and 1.91 and they both do the same. When I used 1.3 it said I needed 1.9.xxx to attempt what I'm doing so I don't think that's going to help.
 

privateye

Established Member
Hi there, I'm trying to patch the Shining force 3 difficulty mod from shining force central into my scenario 1 translated game and I'm running into the issue where the patcher runs but then conitnues to use up more and more memory until it has taken everything my system has. I've left it running for 10 minutes or so but it never completes.
Give SSP v1.95 a try, it's included with the Wachenröder entry in the Sega Saturn 27th Anniversary Game Competition:
https://segaxtreme.net/threads/sega-saturn-27th-anniversary-game-competition.25009/post-182099
 
Top