SSF Android version reads no CD image despite availability of directory

Hello, I've been recently into emulation on Android. I've tried out the Saturn RetroArch cores and I gotta say, I'm not too fond of them because they all have different issues each (both Yabause and YabaSanshiro have buggy graphics, and Beetle Saturn is rather slow and has noisy audio), so I decided to get my hand on the Android port of SSF.

While I'm fine with the minuscular rudimentary UI, the biggest problem for me is the fact that it refuses to read my CD images (either in CHD or BIN/CUE, which are both actually supported by the emulator). The tutorials I've read recommend that I put them on the Android/data/com.xrea.g2.aaaaaaaa.ssf/files directory, but this doesn't work in my case. It still gives me the "Not found CD image." message. I've also granted file and folder access permission to the app, still with the same result.

I know it's probably not gonna get much attention, but any help will be appreciated (especially if it works!). As a side note, I'm using a Samsung Galaxy A05s (Android 13).