• Rise from your gwave!

Need help with my modem

Discussion in 'Computer's Discussion' started by Gear, Sep 19, 2001.

  1. Gear

    Gear New Member

    I finally got a normal phone line (instead of the cordless that I had) and I can't get my PC modem to work properly. I connects me to internet; but then I can't even get to a small site without waiting more than 6 minutes.

    The modem is a motorola SM56. I read the manual and put it in v90 and v34, enable/disable error correction, flow control, etc; but nothing worked. I did the same with the windows settings.

    In the same line I used a 28.8 modem from a laptop I have and it works perfectly.

    Please help me, I'm clueless with what may be wrong.
     
  2. megametalgreymon

    megametalgreymon New Member

    motorola modem? is it a "software" modem (ie using your cpu to emulate some of the chips to reduce costs)

    what spec is your pc if so
     
  3. IceDigger

    IceDigger Founder Staff Member

    Yea, buy a hardware modem.

    Software modem = Headache
     
  4. Gear

    Gear New Member

    It is a "software" modem. I'm running it in a 750mhz Athlon with 256MB ram and winme.

    I'd love to buy a full hardware modem; but here these things are pretty "rare" and expensive :( . And the sites wich I can buy from doesn't send them to my country at a reasonable price.

    I have just used 3 set of drivers; and still don't get any positive result (even a slight improvement).
     
  5. megametalgreymon

    megametalgreymon New Member

    what speed does the windows dial up networking icon in the taskbar showing as being connected at?
     
  6. Gear

    Gear New Member

    I get from 38 to 44kbps mostly.
     
  7. megametalgreymon

    megametalgreymon New Member

    maybe its just not a very good isp your using, is it a free one by any chance? (ie where you just pay for calls)

    you may have a good link between yourself and the isp, but if the isp has a lot of users connected, or very low bendwidth connection to the rest of the web, pages stored on that isp's servers would come up ok, but anything either not cached or on that isp itself would take a while to transfer

    if you can try a different isp
     
  8. Gear

    Gear New Member

    I have tried 3 ISPs.

    One free ISP.

    The ISP of my tel. co. which I pay with the phone.

    Another ISP, which a friend borrowed me his account info.

    Same results in all of them :(
     
  9. megametalgreymon

    megametalgreymon New Member

    can you try that modem in another pc?
     
  10. Gear

    Gear New Member

    Ok, I will try this weekend in a friend's pc.
     
  11. Gear

    Gear New Member

    A friend tried the modem in a 1Ghz P4 (or PIII, I'm not prety sure) with 128MB ram and win98. The modem worked fine there.

    I have to install win98 (winme crashed down); but still the modem doesn't work in my house. By the way, now my PC has 442MB ram.
     
  12. megametalgreymon

    megametalgreymon New Member

    maybe you will have better luck with win98 over me with the modem, although it shouldnt make a difference

    if not what resources has it grabbed for the modem?
     
  13. CyberWarriorX

    CyberWarriorX New Member

    Those modems are just a real pain(I unfortunately used to own one myself - luckily it died on me so I had to grab a different one). Could be some kind of hardware conflict. You may also want to try adjusting the send and receive buffers to see if that makes a difference.

    Cyber Warrior X
     
  14. Gear

    Gear New Member

    I don't remember well which resources takes it. My friend still has it.

    It were IRQ 9 and a memory interval like D0080000-EFEFFFFF (this is the thing I don't remember well; I remember just the number of digits).
     
  15. megametalgreymon

    megametalgreymon New Member

    thats not going to help with it being on irq 9, the correct irq should be 3 or 4, if your not using the com posrts on your machine, disable them, then install your modem, that should make it grab the correct resources

    what port is it getting allocated to as well?
     
  16. Gear

    Gear New Member

    I takes com3 or com4. It changes when I unplug and plug again. And no way I can change it to irq3. Windows doesn't allow me to do that (I already deactivated the other com ports).
     
  17. Curtis

    Curtis Member

    Yeah, the IRQ's are probable your problem.

    Newer versions of Windows has the annoying habit of assigning one IRQ to many resources, including graphics cards and sound cards, and it doesn't help having too many devices sharing a single IRQ.

    Give it a dedicated IRQ (any will do, really) and all should be well.
     
  18. megametalgreymon

    megametalgreymon New Member

    irq 9 really doesnt help, since its supposed to be used by the pc to access the upper irq lines (along with irq2) its not supposed to be used by any devices in the pc at all.

    look in your bios for a setting for either the com port or irq for the modem (some newer motherboards have this option)
     
  19. Gear

    Gear New Member

    Shit, I can't change the irq. Neither from bios/motherboard (doesn't have the option) or windows (refuses to let me change any resource).

    I hate this damned modem so much...
     
  20. megametalgreymon

    megametalgreymon New Member

    i dont really see what you can do then, other than replacing the modem with a hard ware one with jumpers for the port/irq or getting an external modem (which is what i did about 2 years ago when i had a similar problem) is either irq 3 or 4 shown as being free in windows device magager (double click on computer to see whats available)
     

Share This Page